Prince of Persia 3D (Win7 64bit)

Report bugs, errors, problems, etc.

Prince of Persia 3D (Win7 64bit)

Postby daemonicusprince » Tue Sep 06, 2016 6:16 pm

Mostly use Mac for professional reasons, picked up a cheap refurb Dell on Ebay to run some of my childhood games. Dell, Win7pro, SP1, 64 bit. Most of the games work, but not one of my favorites, Prince of Persia 3D. Tried using ISOs I made from my hard copy of the game, tried using the bootlegs that the creators claim would work on win7, nothing. Installs fine, but come time to run the game, double-click... and... nothing.

I'm not extremely tech savvy, not sure what's causing it, whether a 32/64 bit issue (tried running it in compatibility for 98/Me, which the game was originally made for) or something else. Someone in the PoP forums linked me here, tried installing and running nGlide not really knowing what it is, that didn't work either, does anyone have any ideas?

Posts: 971
Joined: Fri Jan 07, 2011 9:29 am

Re: Prince of Persia 3D (Win7 64bit)

Postby Gamecollector » Tue Sep 06, 2016 6:25 pm

PoP 3d not supports the glideAPI so nGlide can't help.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Return to “Problems”

Who is online

Users browsing this forum: No registered users and 4 guests