Elder Scrolls Redguard

General discussion about nGlide.
Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Elder Scrolls Redguard

Postby Gamecollector » Sat Feb 08, 2014 3:32 pm

Play cd is the mixed-mode cd. So - .iso isn't the correct option.
About -freesize - DOSBox have troubles if this parameter is more than 512.
Don't mount the game directory as C, use 1 level above. So - the game will be in C:\Redguard in DOSBox.
Edit Redguard\system.ini and set [system]/animation_drive=d:\.

The game is working perfectly with "mount d i:\ -t cdrom", i is the drive letter of the cd (real or virtual).
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Prowler
Posts: 6
Joined: Sun Feb 02, 2014 11:34 am

Re: Elder Scrolls Redguard

Postby Prowler » Sat Feb 08, 2014 7:37 pm

I'm not entirely sure what you mean with iso not being the right option, after all I was mounting an .iso file and not a virtual drive? As to mounting the game folder to c:\redguard instead of c:, is that even possible? DOSBox doesn't seem to take it.

Now, my mounting commands are this:

@echo off
mount c "C:\REDGUARD\"
mount d "E:\" -t cdrom
c:

Plain and simple, and Play.iso is mounted to E:\. The drive in system.ini is set to D:\. Yet no luck...

The error I mentioned is actually: Critical Disk Error, RedGuard can not run. So, not the disc, but the disk.

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Elder Scrolls Redguard

Postby Gamecollector » Sat Feb 08, 2014 10:20 pm

Iso includes data track only. Not the cd-audio.
Use .cue/.bin, .ccd/.img/.sub or any other BINARY formats.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1472
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Elder Scrolls Redguard

Postby Zeus » Sun Feb 09, 2014 1:58 am

Prowler wrote:Critical Disk Error, RedGuard can not run.

You're getting this error because you're mounting your game directory as C drive. You need to create "games" folder in c:\, move your game to c:\games\redguard and change mount command to: mount c c:\games.

P.S. If you're planning to play the game with nGlide, use 1.00 / 1.01 until 1.03 release. Main menu is bugged with 1.02.

Prowler
Posts: 6
Joined: Sun Feb 02, 2014 11:34 am

Re: Elder Scrolls Redguard

Postby Prowler » Mon Feb 10, 2014 7:21 pm

I thought we'd finally found the obvious source of the problem, but alas, still getting the error. I've placed the game folder in C:\DOS\ and mounted that to c:.

A small side question, if you're not using a launcher, then how would you navigate to the actual .exe? Mounting the game folder to e:?
Last edited by Prowler on Sat Feb 22, 2014 3:56 pm, edited 1 time in total.

User avatar
Zeus
Site Admin
Posts: 1472
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Elder Scrolls Redguard

Postby Zeus » Mon Feb 10, 2014 9:38 pm

Your autoexec section should look like this:

Code: Select all

[autoexec]
# Lines in this section will be run at startup.
# You can put your MOUNT lines here.

mount c C:\DOS
mount d E:\ -t cdrom -noioctl

c:
cd redguard
rgfx.exe


Prowler wrote:A small side question, if you're not using a launcher, then how would you navigate to the actual .exe? Mounting the game folder to e:?

With "change directory (cd)" command.

Prowler
Posts: 6
Joined: Sun Feb 02, 2014 11:34 am

Re: Elder Scrolls Redguard

Postby Prowler » Sat Feb 22, 2014 3:52 pm

Thanks Zeus, it seems that did fix it! One part of the issue was my launcher, apparently, as it automatically mounts the game folder to c:. Now onto tweaking performance.

_#_
Posts: 2
Joined: Mon Jun 23, 2014 12:37 pm

Re: Elder Scrolls Redguard

Postby _#_ » Mon Jun 23, 2014 12:45 pm

hi, I'm trying to run Redguard on win8.1 x64, I'm with a i5 quad core.
I followed the instructions:

1. install redguard 3dfx normally
2. get ykhwong's dosbox latest version
3. delete glide2x.dll file from dosbox folder
4. Download and install nGlide
5. install daemon tools and mount play cd (.cue)
6. Edit dosbox.conf (set memsize=63 and fullscreen=true, joysticktype=none, splash=false, cycles=max)
7. add this to [autoexec] section):

mount c d:\games -freesize 512
mount d f:\ -t cdrom -noioctl
c:
cd redguard
rgfx.exe


in the end, when I run rgfx.exe, I got a black screen, no menu
I tried to set cycles=20000 on dosbox, then cycles=30000 and frameskip=1, that's what I read here, but same results.
should I do something to set only 1 core to work with dosbox? how can I do it?

EDIT: I also double-checked my drives and they are loaded fine. animation_drive in system.ini is d:\
I tried to change the mount line for the cd in: mount d f:\ -t cdrom (without -noioctl)
still got black screen

User avatar
Zeus
Site Admin
Posts: 1472
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Elder Scrolls Redguard

Postby Zeus » Mon Jun 23, 2014 3:49 pm

Try launching DOSBox with a batch file.

Create dosbox.bat in DOSBox directory with:

SET SDL_VIDEODRIVER=directx
dosbox.exe

_#_
Posts: 2
Joined: Mon Jun 23, 2014 12:37 pm

Re: Elder Scrolls Redguard

Postby _#_ » Mon Jun 23, 2014 7:41 pm

thank you, now it works! I can play fine, but with no audio. I will try to read previous posts and find a solution myself

EDIT: I noticed I can't' configure the audio drivers in the options panel found on the playdisk, no configuration works (additionally, every time i open the options panel I must edit the system.ini file because it changes the cd drive, but that's normal).
I thought I didnt need to configure audio drivers there if I run the game with dosbox. thats my [sblaster] confuguration on dosbox:
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=44100
hardwarebase=220
goldplay=false

EDIT 2: I just fount setsound.exe in redguard/sound folder and opened it with dosbox, that should do the trick

EDIT 3: I had to open the option panel again to make it work (and re-set animation_drive=D:\). now all works perfect

LAST EDIT: I managed to make it work without the CD in the virtual drive. just copy all the files in the CD and paste in a folder like C:\Redguard\CD, then edit the system.ini entry animation_drive accordingly (in my case, animation_drive=C:\Redguard\CD). remember to remove the mount CD line in dosbox conf too.


Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests