Nglide with ATi legacy cards

Report bugs, errors, problems, etc.
Locked
User avatar
Zeus
Site Admin
Posts: 1623
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide with ATi legacy cards

Post by Zeus » Thu Oct 10, 2013 4:04 pm

Gamecollector wrote:Can a similar fix be created for the Heretic II version 1.00?
WhiteMagicRaven wrote:Did you can test please this is happen on Heretic II 1.06a? its xplosiv edition of heretic2
http://heretics-hexens.ucoz.com/temp/quake2.zip <- this file its update it to 1.06a
can you do patch to this version too please.
Done.


Gamecollector
Posts: 983
Joined: Fri Jan 07, 2011 9:29 am
Location: RU

Re: Nglide with ATi legacy cards

Post by Gamecollector » Thu Oct 10, 2013 11:07 pm

Zeus, fix the new patch for Heretic II, you forgot empty directories in "For Heretic2 v1.06".
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1623
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide with ATi legacy cards

Post by Zeus » Thu Oct 10, 2013 11:40 pm

?

there's only quake2.dll in 1.06 dir.

Gamecollector
Posts: 983
Joined: Fri Jan 07, 2011 9:29 am
Location: RU

Re: Nglide with ATi legacy cards

Post by Gamecollector » Fri Oct 11, 2013 1:11 am

Zeus wrote: there's only quake2.dll in 1.06 dir.
*Censored*.
Far Manager glitch...
http://img547.imageshack.us/img547/5359/rrr2.jpg
Sorry...
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1623
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide with ATi legacy cards

Post by Zeus » Fri Oct 11, 2013 2:21 am

Looks like it doesn't fully support modified zips. I created a new zip file and now it shows the content properly.

Gamecollector
Posts: 983
Joined: Fri Jan 07, 2011 9:29 am
Location: RU

Re: Nglide with ATi legacy cards

Post by Gamecollector » Sat Oct 12, 2013 2:33 am

Jane's AH-64D Longbow 2 with the nGlide 1.02 - work flawlessly.
Jane's AH-64D Longbow 2 with a real Voodoo2 - no sound, music only (well, the sound was once).
I love the oldgaming. :)
There was something about this error in SimHQ, but this was so long ago...
P.S. Can be fixed by MSS32.dll replacing (like Deathtrap Dungeon and Jane's Combat Simulations F-15)

Hype: the Time Quest - have deleted the EmulateDirectDrawSync ACT fix for this game (it was in my custom database since old nGlide versions). The result is - can't reproduce movies freeze. Good.
P.S. Well, the game can still ctd after the intro (4th-5th intro play, the method is - "New game"/Esc to break the intro/Esc and select "go to main menu"/repeat). But this is much better then freezing anyway...
Attachments
Hype.JPG
Hype.JPG (15.51 KiB) Viewed 4118 times
Last edited by Gamecollector on Sun Oct 13, 2013 2:09 am, edited 1 time in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 983
Joined: Fri Jan 07, 2011 9:29 am
Location: RU

Re: Nglide with ATi legacy cards

Post by Gamecollector » Sat Oct 12, 2013 11:28 pm

Jane's Combat Simulations: F-15 - APC trouble.
Crosshair, artifical horizon levels etc.
Attachments
F15voodoo2.jpg
F15voodoo2.jpg (73.23 KiB) Viewed 4113 times
F15nGlide.JPG
F15nGlide.JPG (57.78 KiB) Viewed 4113 times
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 983
Joined: Fri Jan 07, 2011 9:29 am
Location: RU

Re: Nglide with ATi legacy cards

Post by Gamecollector » Mon Oct 14, 2013 11:58 pm

Killer Loop with the nGlide 1.02 - all is ok.
Killer Loop with a real Voodoo2 - only cursor keys and Enter are working... WtF?
P.S. Fixed by the EmulateUSER ACT fix.
Still - no CDA in the 1st run after a rebooting. Sometimes the game freeze after intros (before the VCC logo).

Kingpin: Life of Crime - again glitches with the 1st run after the installation (gamma with a real Voodoo2, no CDA). Restart the game once.

King's Quest: Mask of Eternity - ctd is gone.
P.S. Real Voodoo2 - solid FPS even with "dynamic lighting"=on. Unfortunatedly nGlide is still lagging in menus and with dynamic lighting...
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 983
Joined: Fri Jan 07, 2011 9:29 am
Location: RU

Re: Nglide with ATi legacy cards

Post by Gamecollector » Thu Oct 17, 2013 8:31 am

There is something strange with King's Quest: Mask of Eternity + nGlide behavior.
If the "Options" submenu isn't selected once - "Load" and "Save" menus are working with the solid FPS.
After entering the "Options" menu once - all submenus and the game itself is lagging.
Memory leak maybe?
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Locked