NHL 99

General discussion about nGlide.
User avatar
Titus03
Posts: 5
Joined: Wed Feb 06, 2013 1:44 am
Location: Europe

NHL 99

Postby Titus03 » Sat May 25, 2013 5:15 pm

NHL 99 (Demo) was marked to have bugs in the compatibility list.

Edit: Please read the whole post.

I have tested NHL 99 (Full) with nGlide 1.0 and it appears to be fully working with a NVIDIA card. The game runs actually better with nGlide than D3D. (D3D needs more tweaking to work.)

What to do:

1) Install NHL 99.
2) Modify nhl99.exe to use just a single core (with a tool like ImageCFG or Setaffinity) in case you have a machine with more than just one core.
3) Install registry patch (attached).
4) You can change resolution from the game interface (and apply triple buffering via Registry Editor).

Notes:

- The game is tested with nGlide on Windows XP, so it is not guaranteed to work with Vista/7/8 by using these instructions.
- Patching the game with EA Sports patch may cause crashes on newer machines. If you patch the game and get the crashes, revert back to 1.0.
- If you disable "Vertical synchronization" from nGlide configurator, you will get a glitch, which will disable fade-effects from the menu screens after playing a match.

Edit:

- Official registry patch has been added to the compatibility list, so the attachment has become obsolete. Use it only if official registry patch does not work for you.
- Using "PatchInstall.bat" provided by the official patch will make point 2 (above) obsolete.
Attachments
NHL 99 with nGlide.jpg
Screenshot
NHL 99 with nGlide.jpg (246.14 KiB) Viewed 3123 times
nhl99_patch.zip
Registry patch
(327 Bytes) Downloaded 495 times

snow
Posts: 2
Joined: Thu Feb 12, 2015 5:48 pm

Re: NHL 99

Postby snow » Thu Feb 12, 2015 6:02 pm

Hi guys,

First of all, many thanks for this fantastic tool to emulate a 3dfx card.

But I have a question regarding NHL 99.
For testing I installed Windows XP 32-bit and the game is runnung properly with D3D and also with nglide.
But the problem I have, the cpu load caused by the nhl99.exe is going to 100% on the first core (AMD Phenom 2 X4 960T) and this avoids to run the game smooth.

It doesn't matter if the game is running with the D3D adapter (configured with the 3D settings tool), or by using the nglide emulation. In both cases the cpu load is on 100% and unfortunately the game is stuttering.

I also tried to run the game in compatibility mode (Win95, Win98), but there is no difference.
I know there is no combination with nglide, but maybe you have a workaround to get the game running faster.

Thanks again,
snow

User avatar
Zeus
Site Admin
Posts: 1476
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: NHL 99

Postby Zeus » Fri Feb 13, 2015 3:12 am

I don't know what to say. I have constant 60fps in 3D simulation on WinXP (real WinXP, not in VMware) + Core2Duo 3.16GHz + nGlide 1.03 (measured with Fraps).
All I'm using is the patch from nGlide's compatiblity list (no W95/98 compatibility modes).

snow
Posts: 2
Joined: Thu Feb 12, 2015 5:48 pm

Re: NHL 99

Postby snow » Fri Feb 13, 2015 9:40 am

Hi Zeus,

I already checked the framerate by using fraps and I also get 60 fps with vsync enabled and between 200 - 300 with vsync disabled. But unfortunaltely the game is not runing smooth. I mean it's not really stuttering, it's more a kind of "micro stutters" like playing with a SLI, or Crossfire setup. As already mentioned it's not a problem with nglide. From what I can see it's a problem with the 100% cpu load caused by the nhl99.exe process. And that's a little strange because my AMD Phenom cpu is running with 3Ghz. I already overclocked to 4Ghz, but the issue is still the same, this means 100% cpu load on one core.

I will now try to check with another harware configuration. Maybe it's running better with an Intel cpu.

Thanks,
snow


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests