Page 1 of 2

No music in Gex 2

Posted: Tue Nov 18, 2014 10:23 pm
by spyder256
So I just installed Gex 2. I installed the patch and everything (related to video) seems to be working fine. Except for that there is no music at all in the game. And during the intro movies, the first one plays okay, but then in the Midway one sound plays for a second and then stops. Then in the movie where Gex talks, it plays the first second of audio in sync, but then the audio skips to a random place in the scene while the video plays normally. The next part with the title plays fine. Then the next part where the camera is flying around to the menu is where there is no music at all, which continues in game.

I didn't post this in the "problems" forum since I'm not sure this is a problem with nglide. I doubt it is. And since this is such an old, not so popular game, there isn't exactly a big community surrounding it, and I couldn't find any info anywhere, so I'm not sure where else to go. Thanks for any help.

Re: No music in Gex 2

Posted: Tue Nov 18, 2014 10:29 pm
by Gamecollector
You must set the audio acceleration level to "Basic" in WinXp for Gex.
Dunno about Vista and Win7, but IIRC there is no such option in these OSs...

Re: No music in Gex 2

Posted: Tue Nov 18, 2014 10:51 pm
by spyder256
Ah, forgot to mention. I'm running Windows 7 64 bit. Where would this audio acceleration option be found in XP?

Re: No music in Gex 2

Posted: Tue Nov 18, 2014 11:00 pm
by Gamecollector
Control Panel/Sound and audio devices/Audio/Sound Out/Preferences/Recording Quality/Hardware acceleration.
Or run dxdiag.exe. Then Sound/Audio Acceleration Level.

Re: No music in Gex 2

Posted: Tue Nov 18, 2014 11:15 pm
by spyder256
Yeah, been doing some googleing and there doesn't seem to be any option in Windows vista and up :/

And there's no options in Dxdiag under the sound tabs.

Re: No music in Gex 2

Posted: Wed Nov 26, 2014 1:41 am
by AnarchoCapitalist
it could be that you don't have the CD configured right; IIRC it used redbook and I have image of it. I seem to remember music playing but i am not 100% sure. I will be a bit too lazy to check in the foreseeable future; I wish I could help more.

Re: No music in Gex 2

Posted: Thu Feb 05, 2015 2:08 pm
by snaphappy7530
Hey guys I've got the same issue too.

I've installed the latest version of nGlide (v.1.03) and the Gex patch.

I've tried changing the drive letter of my virtual CD drive to B which solved a unrelated problem for someone here (did nothing for me): http://www.vogons.org/viewtopic.php?f=8&t=40448
I've tried lowering the sample rate of my audio in the Realtek manager which did nothing.
I've tried running the patched EXE in compatibility mode, which did nothing.

I have a very old laptop running XP that I might try installing it on later and see if I can at least get it working there.
Any ideas on what we can do, I'll keep trying to fix it but idk if I'll get anywhere.

My PC specs:
Win 7 64bit SP1 (completely up to date)
Geforce 570
Asus Z87M-Plus
Intel i5 4570

Re: No music in Gex 2

Posted: Thu Feb 05, 2015 3:51 pm
by Zeus
Try this.

Re: No music in Gex 2

Posted: Fri Feb 06, 2015 6:59 am
by snaphappy7530
Thanks Zeus.
I tried compiling the code but I had no idea what I was doing, so I grabbed the .ddl's from Tie Fighter which fixed the issue somewhat. Music plays now but it does not loop. Putting the converted files in the "music" folder does nothing. I deleted them and the music still worked.
A work-around I've discovered is pausing the game and accessing the menu. This reloads the music and gets it working again.
Any ideas on how to get the music looping?

Re: No music in Gex 2

Posted: Sun Feb 22, 2015 5:36 am
by snaphappy7530
Bit of an update.
My Win7 PC died (will hopefully have it within a week or two) and so did my old WInXP craptop that could run Voodoo natively.
I do have Gex2 on PS1 but idk if I'll be able to use and test it.

I've noticed some SFX like the "1UP" sfx when collecting enough items do not occur when the music stops playing. Pausing the game DOES NOT fix this issue, just restarts the music.
I've also noticed drops from dead enemies can get stuck in walls, I don't remember this in the original but that was 12yrs ago.
There is also a strange transparency issue occurring on the hub world, on the edge of view distance, ground becomes semi transparent and you can see TVs through them.
I'm not sure of those last two issues are an issue with Nglide or just bugs in the original game. Just thought I'd mention it.

Any ideas for next plan of action?