International Rally Championship

General discussion about nGlide.
Bladeforce
Posts: 39
Joined: Sat Feb 18, 2012 11:27 pm

International Rally Championship

Postby Bladeforce » Sun Feb 19, 2012 12:02 am

Hello, as it's my first post may i just thanks the coding guys for this excellent piece of software. I am reliving my childhood dreams of being able to play these games in all their 3dfx glory, thanks!

Well I have to say most of my 3dfx games except one ;-)

International Rally Championship

I have uploaded a picture to show the problems it has running. I have already downloaded the 3d card patch and it is selectable in the option as 16 bit accelerated graphics.

It was worse than this but selecting run in windows 98 compatibility mode seems to have helped it a little. I am running windows xp with sp3

Any help would be appreciated! :)

irc1.png
irc1.png (504.72 KiB) Viewed 4448 times

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: International Rally Championship

Postby Gamecollector » Sun Feb 19, 2012 12:35 am

Looks like DX5-only game for me. So - nGlide is not the option here.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: International Rally Championship

Postby Gamecollector » Fri Feb 24, 2012 6:14 pm

Well, my version of the cd is from 2000, not the 1998. Plus there are sources with "IRC is having glide support"...
So - the case is still open.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
OldByte
Posts: 16
Joined: Wed Feb 22, 2012 4:31 pm

Re: International Rally Championship

Postby OldByte » Fri Feb 24, 2012 10:12 pm

I doubt this game had 3dfx support, though it runs on my ATI card, some screen flicker though.
When I had an Nvidia card this game would not run at all.
Motherboard: MSI K9A2 CF, CPU: AMD Phenom 9550 2.20GHz, RAM: 4GB DDR2,
GPU: AMD/ATI Radeon HD 6770 1GB DDR4, OS: Windows XP SP3, Windows Vista 64bit SP2

Bladeforce
Posts: 39
Joined: Sat Feb 18, 2012 11:27 pm

Re: International Rally Championship

Postby Bladeforce » Sat Feb 25, 2012 8:47 pm

Well mine is the 98 version. It's odd that it does do some of the effects except the car. If I play it in 3D accelerated mode everything apart from the car and flickering when driving on the course is ok. No in game menus are accessible though, yet menus on main screen are ok

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: International Rally Championship

Postby Gamecollector » Sat Feb 25, 2012 9:25 pm

Current WinXp GPU drivers are maximum DX7+ compatible. Part of the videocards are DX9 only (you have Vista and DX10, so - go to hell, retrogamers!)... No DX5/6 support, so - any old DX game is the potential heap of the graphical glitches.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: International Rally Championship

Postby IceMan » Tue Mar 06, 2012 5:09 pm

This is a bug with later generation nVidia drivers, I'm getting it but didn't used to. Other games that malfunction under new (e.g. 295.73) drivers include Wipeout 2097/XL, Rallisport Challenge (BSOD!) and Boss Rally (in Direct3D mode, in Glide mode it's fine).

I'll be reporting my findings to nVidia, like I did when all the DX5 or so games ground to a halt (which they fixed, maybe it was my useful bug reports with demos to try!), hopefully things will get better in future!

In the meantime, to definitely play old games without glitches, get the 163.75 WHQL driver set. Then swap back to newer ones for newer games. Annoying!
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor

Bladeforce
Posts: 39
Joined: Sat Feb 18, 2012 11:27 pm

Re: International Rally Championship

Postby Bladeforce » Sat Apr 07, 2012 9:28 am

I'd just like to report that I have it running fine now. The only difference is that i tried it on xp sp3 originally but in sp2 it works a treat. Thanks for the help and gotta love those microsoft guys, they must really hate the retrogamer! :)

Edit. this is in a virtual machine so it will negate any nvidia driver problem as vmware doesnt emulate an nvidia chip


Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests