Page 1 of 1

Just a quick question about nglide

Posted: Fri Nov 24, 2017 9:40 am
by vortexal
I have previously asked a this before, but I wasn't given an answer. Why does nglide specifically require directx9? I've never seen something like this before, usually when a program requires an older version of directx it works just fine. I've been working with computers pretty much my whole life and I've never come across an issue like this.

Re: Just a quick question about nglide

Posted: Sat Nov 25, 2017 4:49 am
by Zeus
Could this be because you didn't play games released between 2002 and 2017 like Metro 2033, Grand Theft Auto 4 or Skyrim? It's possible most of the software you used utilized DX6/7/8 or OpenGL 1/2 or had separate codepath for partially compatible DX9 devices like yours. One example is Call of Cthulhu: Dark Corners of the Earth. You can run it on Intel GMA 3150, but with half graphics features / all special effects removed and horribly low fps due to the lack of T&L.

When it comes to backward compatibility of the DirectX installer it's true only for a software part. What hardware supports is a completely different topic.