Page 1 of 1

Force 16-bit games running at 32-bits on 64 systems

Posted: Tue Sep 30, 2014 5:18 pm
by AnimalBear
There is a way to fix this?
In larry 7 there is a tool to auto install the game at windows 7 64-bit and make it work perfectly on Larry.

I can´t install NHL 97 to 2000, and the only solution is running on Virtual Machine.
If i copy the videogame in to the windows 7, the game will ask for the CD-ROM, i really need a good solution without using a virtualization and a dual-boot running. :(

I already try this and only works on demo game versions: http://www.reactos.org/forum/viewtopic.php?f=22&t=10988

I have the nocd-patch for no using CD-ROM, but the .exe crashes at the screen. :(

Re: Force 16-bit games running at 32-bits on 64 systems

Posted: Tue Sep 30, 2014 10:36 pm
by Gamecollector
1) NHL 97 cd have 2 versions of the game - DOS and Win95. Use DOSBox and the DOS version.
2) I will test this game on Vista 64-bit after I return to home.

Re: Force 16-bit games running at 32-bits on 64 systems

Posted: Thu Oct 09, 2014 1:37 am
by Zeus
AnimalBear wrote:I can´t install NHL 97 to 2000, and the only solution is running on Virtual Machine.
If i copy the videogame in to the windows 7, the game will ask for the CD-ROM

Just copying sometimes is not enough. In some cases you must also dump game keys from windows registry.
EA Sports games store their keys in HKEY_LOCAL_MACHINE\Software\EA Sports.

Open regedit.exe, navigate to HKEY_LOCAL_MACHINE\Software\EA Sports, right click on NHL 2000 (or any other EA game you want to play), choose Export and save it as gamename.reg file.

If your target OS is 64-bit, open .reg file in a notepad and replace all strings "HKEY_LOCAL_MACHINE\\Software" to "HKEY_LOCAL_MACHINE\\Software\\Wow6432Node".

Now copy your game together with .reg file to a new system. Once copied, double click gamename.reg file.

Make sure the game is in the same location (folder) on new system and your CD drive uses the same letter. Otherwise, you'll have to re-adjust all game paths stored in .reg file too.