Compatibility List

New ideas and suggestions.
WhiteMagicRaven
Posts: 98
Joined: Sun Feb 28, 2010 11:10 pm

Re: Compatibility List

Postby WhiteMagicRaven » Thu Mar 10, 2011 3:47 pm

In Windows XP it works perfectly without any compatibility. Only one thing, you maybe use old heretic2 patch it to 1.06

myloch
Posts: 63
Joined: Fri Sep 24, 2010 8:31 pm

Re: Compatibility List

Postby myloch » Fri Mar 11, 2011 2:43 am

Heretic 2 needs windows 95 compatibility setting to run (without it, the game frequently crashes on level loading screen).


Lol please forget what I said because It frequently crashes with w95 compatibility setting too!
I'm using windows seven and my heretic 2 is labeled v1.00. Never had problems running it on Xp.
Upgrading to 1.o6 doesn't seem to do much. Let's say it's unstable but playable on seven (and probably vista) :roll:

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Compatibility List

Postby Gamecollector » Fri Mar 11, 2011 7:37 am

Tested. Looks like the cause of the crashes is the sound engine.
Lowering of the sound acceleration in Xp cured the loading screen CTDs in Heretic II version 1.00 for me. In the 1.06 you can choose the sound provider and this trouble is not appearing.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Dark Savant
Posts: 9
Joined: Wed Apr 27, 2011 5:01 pm

Re: Compatibility List

Postby Dark Savant » Wed Apr 27, 2011 5:19 pm

Any progress with Redguard? I would love to see this one on compatibility list someday. :)

User avatar
Zeus
Site Admin
Posts: 1473
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Compatibility List

Postby Zeus » Wed Apr 27, 2011 11:03 pm

Any progress with Redguard

Not yet...

User avatar
Zeus
Site Admin
Posts: 1473
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Compatibility List

Postby Zeus » Thu May 12, 2011 3:56 pm

Just found this: Redguard is working with Ykhwong's build.

WhiteMagicRaven
Posts: 98
Joined: Sun Feb 28, 2010 11:10 pm

Re: Compatibility List

Postby WhiteMagicRaven » Fri May 13, 2011 11:41 am

I guess its because after Glide initialization redguard use software mode for drawing menu loading screen etc,
nGlide can't work with that in this moment.
Same happens with Descent II, we see 3dfx logo and next is black screen (and nothing happen) but its wrong descent II draw message about 3dfx version, and you must press esc key to continue, you can test it with Ykwong build as redguard.
With nGlide Descent 2 work too, after 3dfx just press esc when you see black screen (but you should see warning message instead black screen)
also it might be good tip here http://www.si-gamer.net/gulikoza/
RedGuard (set the cycles to <20000 for the game to start)

User avatar
Zeus
Site Admin
Posts: 1473
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Compatibility List

Postby Zeus » Fri May 13, 2011 1:45 pm

I guess its because after Glide initialization redguard use software mode for drawing menu loading screen etc,
nGlide can't work with that in this moment.

No, that's because Ykhwong's DOSBox build handles cycles=auto variable better than the other 2 DOSBox builds. Descent 2 'green message' is another story.

fla_2
Posts: 1
Joined: Sat Jun 04, 2011 1:17 am

Re: Compatibility List

Postby fla_2 » Sat Jun 04, 2011 1:33 am

Driver's Education '99 from Sierra runs under XP using nGlide so it should be in the compatibility list. Actually it runs with uglier graphics without nGlide but after installing nGlide you get two "Glide" resolutions available in the Driver's Education graphics options. Using those you get nicer graphics and the spinning 3dfx logo at the beginning. :D Congrats on a cool wrapper.

WhiteMagicRaven
Posts: 98
Joined: Sun Feb 28, 2010 11:10 pm

Re: Compatibility List

Postby WhiteMagicRaven » Mon Aug 01, 2011 9:37 am

Heretic 2 (Demo)- (1.06) and Heretic Full versions 1.00 and 1.06
Hexen 2 (GL Hexen 2)- (HeXen II: The Beginning of the End 0.38, 1.03, 1.08, 1.09, 1.10, 1.11) and demo versions 1.11 an 0.48 works with nglide too.
Hexen 2: Portal of Praevus- ver 1.12 and 1.12a
And almost all hexen2 source ports works with nGlide (doesnot bother about source ports)
so everything is work!
list most looks like this

HeXen II: Demo
HeXen II: Continent of Blackmarsh
HeXen II: The Beginning of the End
HeXen II: Portal of Praevus
Heretic II: Demo
Heretic II

--------------
for demo versions you can add links for download =)
0.48 here ftp://ftp.idsoftware.com/idstuff/hexen2/H2Demo.exe


Return to “Suggestions”

Who is online

Users browsing this forum: No registered users and 1 guest