Page 1 of 2

Ultim@te Race Pro - Zeus please support 1.50 patched version

Posted: Mon Dec 08, 2014 8:29 am
by IceMan
The urp_patch.zip you have on your compatibility site seems to be applied to the original 1.0 release (looking at the Properties/Details tab of the .exe). The 1.50 patched version adds things like EAX audio and other things (you can get the patch from The Patches Scrolls site).

As an FYI, here's what the 1.50 patch added:


Ultim@te Race Pro v1.50
********************************************************************************

RIVA TNT Support : no more problem with the keyboard


Ultim@te Race Pro v1.40
********************************************************************************

Ultim@te Race Pro v1.40 fixes the following problems on the Ultim@te Race Pro release version:

Sound:
------

1) Support for CreativeLabs EAX Audio Extension (enable reverb sound).
Ultim@teRace supports 8 (default) or 32 hardware sound buffers.
If your sound driver supports 32 voices, You can use -SB32
(on the command line) to enable them.

2) Support for DirectSound3D (2 and 4 speakers)
This option can be disabled by using -DS3DOFF (on the commandline).


Video:
------

1) Voodoo 2 : MipMap + Trilinear filtering

2) 4Mb frame buffer Voodoo 1 & 2 : additionnal 800x600 videomode

3) Voodoo 1 & 2 (4Mo each TMU) : MipMaping.

4) MPact 3D card : Direct3D mode full support

5) 3dfx with more than 4 Mb of memory can accces to 800x600 video modes.

6) Jazz Multimedia Adrenaline Rush 3D (Voodoo Rush) works well now.
Glide 2.43 or greater recommended.

7) Mipmap activated on 3dfx voodoo 1 with 6 Mb of memory.
Glide 2.43 or greater recommended.

8) Texture bug on 3dfx Voodoo2 with 12 Mb of memory is removed.
Glide 2.5 or greater recommended.

9) Mipmaping and trilinear filtering is only avaible with 3dfx voodoo2
with 12Mb of memory.
Glide 2.5 or greater recommended.

10) ZBuffer works on all 3dfx boards


Network :
-------

1) Internet gameplay improvement, fixing of connection problems and malfunctions.

2) Cable modem support for winsock2:
Add the following lines in the file C:\windows\win.ini in the section: [LibsysNetwork]
REGULARTCPIPENABLED=TRUE
This will add a full DirectPlay TCP/IP protocol.

3) Choice of the network adapter on multiple IP addresses systems for TCP/IP (Winsock2 & DirectPlay) protocol:
Add the following lines in the file C:\windows\win.ini in the section: [LibsysNetwork]
MULTIPLEIP=TRUE

4) Update of Winsock2

5) Unability to Hack cars specifications

6) Setting manually network events frequency:
Add the following lines in the file C:\windows\win.ini in the section: [LibsysNetwork]
MSGPERSECRECV2_IPX=16 ;Leave this value unchanged
MSGPERSECRECV16_IPX=64 ;Raise this value until you get smooth network cars (Shouldn't exceed 256)
Be aware that setting too high or improper values will have the opposite wanted effect !

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Mon Dec 08, 2014 10:37 pm
by IceMan
Also one more thing; if you don't use Win98 or earlier compatibility, the game won't save it's settings (graphics/controls/player name/etc), however if you do use Win98 or earlier then the handling goes out (one direction turns smoothly, the other like a hard digital lock-to-lock) and also GSYNC only enables if using > Win98 mode on my screen. Not sure if it can be made to save too without compatibility settings, that's probably more specific?

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Fri Dec 12, 2014 2:54 am
by Zeus
IceMan wrote:The 1.50 patched version adds things like EAX audio and other things (you can get the patch from The Patches Scrolls site).

It also introduces broken transmission screen.. ;)

IceMan wrote:Also one more thing; if you don't use Win98 or earlier compatibility, the game won't save it's settings (graphics/controls/player name/etc), however if you do use Win98 or earlier then the handling goes out (one direction turns smoothly, the other like a hard digital lock-to-lock) and also GSYNC only enables if using > Win98 mode on my screen.

With 1.00 and Win7?

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Fri Dec 12, 2014 8:41 pm
by Zeus
Patch updated.

Disable compatibility mode and click PatchInstall.bat. Let me know if it also fixes your handling/GSYNC issues.

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Sat Dec 13, 2014 4:47 pm
by IceMan
I'm running it on Win8.1 64bit. Thanks for the update, will try it soon.

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Sat Dec 13, 2014 8:07 pm
by IceMan
Okay it's not really working. First up, I don't need to install your SDB patches; the game behaves identically with or without them.

Much as before, if I use no compatibility it'll run fine, with GSYNC and handling with keyboard is fine, but the game will never save any changes to settings (graphics/sound/player name/etc). If you save changes whilst using Win98 mode then set it back to no compatibility mode, then those changes WILL be loaded, but no new changes will be saved.

With Win98 or WinXP SP3 compatibility mode I gain the ability to save settings, but also have bad handling and no GSYNC (I think the latter is due to how compatibility renders the screen, as any game using it won't enable GSYNC). With Win98 compatibility there's a critical bug too; when you hit Esc then F1 to exit a race, the game crashes with an error about "DirectX error" and "please reinstall DirectX". This doesn't happen with no compatibility mode set, but interestingly also doesn't happen when using WinXP SP3 compatibility mode.

Finally, the main reason to use 1.50 is not so good either... on my old WinXP machine with SB Audigy ZS2 the game would detect EAX and show a banner on the race loading screens to say so. However on my new PC I tried using Creative ALchemy against the game folder, but if I do, I get a message from the game "LIBSYS Error: LS_ERROR: 19 Sound Error Set Format Primary Error!" and it won't even start, regardless of compatibility mode!

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Sun Dec 14, 2014 12:25 am
by Zeus
IceMan wrote:I don't need to install your SDB patches; the game behaves identically with or without them.

This shouldn't be the case... unless you renamed game executable or the patch hasn't been installed. Check "Uninstall or change a program" dialog for a "Ultimate Race Pro Patch" entry.

IceMan wrote:However on my new PC I tried using Creative ALchemy against the game folder, but if I do, I get a message from the game "LIBSYS Error: LS_ERROR: 19 Sound Error Set Format Primary Error!" and it won't even start, regardless of compatibility mode!

Possibly ALchemy bug.

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Sun Dec 14, 2014 5:15 pm
by Gamecollector
IceMan wrote:I don't need to install your SDB patches; the game behaves identically with or without them.

The VirtualRegistry ACT fix - fixes "settings aren't saved" problem.
The EmulateSlowCPU ACT fix - the game freezes w/o it (wrong timers).
Dunno about GlobalMemoryStatusLie - maybe it is needed with RAM>4GB. My nGlide test PC works ok w/o it.
So - you can't run this game w/o .sdb patching.

Zeus, there is 1 question. If I try to start the version 1.0 with a real Voodoo2 - I get 2 popups from WINIPGFG about wsock32.dll on the loading screen (can be seen in the System event log)(just press enter twice to continue loading). But if I use nGlide - there is no popups. You have a dirty hack special routine in nGlide to supress them or the cause is different? :)

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Sun Dec 14, 2014 5:38 pm
by Zeus
Interesting...

I have no idea what it might be (nGlide doesn't have any code that supress them).

Re: Ultim@te Race Pro - Zeus please support 1.50 patched ver

Posted: Mon Dec 15, 2014 12:28 am
by IceMan
Zeus wrote:
IceMan wrote:I don't need to install your SDB patches; the game behaves identically with or without them.

This shouldn't be the case... unless you renamed game executable or the patch hasn't been installed. Check "Uninstall or change a program" dialog for a "Ultimate Race Pro Patch" entry.

Where do I find this dialog? If it's in Control Panel > Add/Remove programs then there's no log of any patches. I suspect Win8.1 may have more compatibility fixes in it, as many games (e.g. Road Rash) that people say has problems with colours works fine... or maybe that's the Nvidia card doing one thing right at least!