Page 1 of 1

Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Sat Apr 09, 2016 6:56 am
by drcho805
Hello, I am playing Diablo2 - Lord of Destruction via nGlide.

Yesterday, I installed Diablo2 1.14b patch and it cannot be run.

I could play diablo2 before installing the patch clearly.

How can I do about this problem?

Lastly, I am using Windows 7. Please let me know the solution if you could solve it.

Thank you.

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Sat Apr 09, 2016 2:21 pm
by mclusky
Yep, same here. Diablo2 1.14b patch installed and no more glide for me. :< I'm using W10.

What's odd, is that Swenwrapper works with 1.14b. But I would have nGlide working - support for many more games... ;)

edit: I tried with -3dfx in my shortcut, but then it shows:

Code: Select all

---------------------------
Diablo II Error
---------------------------
Error 1: Diablo II is unable to proceed. Unsupported graphics mode.
---------------------------
OK
---------------------------


edit2: hm, it's also doesn't work with patch 1.14a too...

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Sat Apr 09, 2016 3:23 pm
by Zeus
Glide API support has been removed in 1.14b (2016 patch), so the only option to play it with glide wrappers is to revert back to 1.13c (or older).

mclusky wrote:What's odd, is that Swenwrapper works with 1.14b

Impossible.

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Sat Apr 09, 2016 11:10 pm
by mclusky
It is somehow possible. I had only to make a shortcut to exe with -3dfx command line. And put glide3x.dll to game catalog and c:\windows\system. Below are screens done on glide emulation (1.14b).

Maybe it's have something to do with these glide3x files?

d2-compar-1.jpg
d2-compar-1.jpg (231.35 KiB) Viewed 10103 times

d2-compar-2.jpg
d2-compar-2.jpg (242.97 KiB) Viewed 10103 times

d2-compar-3.jpg
d2-compar-3.jpg (244.31 KiB) Viewed 10103 times

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Sun Apr 10, 2016 3:13 am
by Zeus
What? So they restored Glide?

Ok, I'll check this and report back...

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Sun Apr 10, 2016 9:24 pm
by Zeus
Ok, I have some news.

Blizzard didn't remove Glide API support in 1.14. They made a bad mistake in new Glide code and as a result killed every glide wrapper except one they tested, Sven's wrapper. :roll:

I submitted a bug in their forums:
http://us.battle.net/en/forum/topic/20742849642

I encourage you to show your support for nGlide there as I have weird impression Blizzard doesn't even realize there are other glide wrappers on the planet.

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Sun Apr 10, 2016 10:05 pm
by mclusky
Thx Zeus, I will bump your thread on BN forum. :)

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Tue Apr 12, 2016 11:17 am
by drcho805
Thank you, everybody!

I'm so happy now!!

Re: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Posted: Wed May 18, 2016 1:21 pm
by Zeus
Success!

Thanks everyone for contribution. :)