Page 1 of 1

Pirates Of The Caribbean

Posted: Tue Mar 29, 2016 9:25 pm
by StoryTeller
I'm currently trying to run Pirates Of The Caribbean (often referred to as Sea Dogs 2, see also here as the title is pretty ambiguous).
When trying to enter the game from the menu by loading or creating a game, it crashes with the alert "ENGINE.EXE has stopped working." With a little bit of research I came to the conclusion it could be the fact that Windows 10 does not support DirectX9 anymore, which could not be installed during the installation of the game for this reason.

My specs are:

OS: Windows 10, 64-Bit (Real OS)
Graphics: Nvidia GTX 765M
CPU: Intel Core i7-4700MQ CPU @ 2.4 GHz
8.00 GB RAM

I've also run test04.exe from:
which has shown me the wanted triangle.

Looking at the registry HKEY_LOCAL_MACHINE > Software > Wow6432Node > bethesta softworks > Pirates of the Caribbean only contains one node "1.000.000" with a single entry of type "REG_SZ" with no value.
Might even be a dead entry though, I've reinstalled the game during trial and error several times, it's now installed on drive E:\

Any suggestions what I could try?

Re: Pirates Of The Caribbean

Posted: Wed Mar 30, 2016 1:08 am
by Zeus
DirectX 9 works flawlessly on Windows 10 and nGlide is a Glide to DirectX 9 wrapper so it won't help your game.
Besides, POTC is a DirectX 8 game.

What you may want to try is WineD3D. Extract all these files from I attached next to engine.exe and try to run the game again.

Re: Pirates Of The Caribbean

Posted: Wed Mar 30, 2016 5:54 am
by StoryTeller
I'm afraid that didn't help, the screen turns black, I get a Windows Notification about my recommendet resolution and the game breaks before reaching the Menu.

Re: Pirates Of The Caribbean

Posted: Wed Mar 30, 2016 12:34 pm
by Zeus
If I recall correctly the game has a config app where you can adjust resolution. Try setting it to native (1920x1080?).

Re: Pirates Of The Caribbean

Posted: Wed Mar 30, 2016 6:54 pm
by StoryTeller
Edit / Windows 7 Virtal Machine attempt

I tried a Windows 7 Professional Virtual Machine again and the game finally runs! Here is what I did, it might help users of a real Win 7 OS, too:

1. Installation: Open the CD drive and execute the setup.exe in compatibility mode with Windows XP Service Pack 2.
2. Deactivate the Windows Firewall
3. Set compatibility mode for ENGINE.EXE to Windows 98 / Windows ME
4. Download the Swift Shader 2.0 Demo here and execute it
4.1 Pick the installation path of the game as the installation path of Swift Shader
5. Execute the game

The game can still crash from time to time, but I played it for 3 hours without problems now.

Old message / Windows 10 attempt

The message is gone, but the problem remains the same Black screen and no menu. In some compatibility settings you can hear the sound of the intro though.

I am currently experimenting with Swift Shader 2.0 Demo, which lead zu limited success. I even managed to run the game from time to time, but it is either lagging extremely, has major texture bugs or the well known "ENGINE.EXE stopped working" message pops up.

Using Swift Shade always leads to a *pling* telling you, you got a new quest, which is the first sound of a new game. After this first sign of life the game usually breaks.

Any new ideas or some tips for the Swift Shade configuration? I might have found something useful there.

The most successful configuration of Swift Shade so far (game runs for a time, then crashes) was:
(Unfortunately, after a restart this configuration never worked properly again.)