Kingpin and lag/micro-stutter

Report bugs, errors, problems, etc.
algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Kingpin and lag/micro-stutter

Postby algeeba » Sat Nov 28, 2015 11:28 pm

Hi.

I'm using the latest nGlide with Kingpin: Life of Crime and I am getting microstutter, lag and a reduction of about 20-30 fps in some places. Just in the first level, looking at a wall or floor I get 60 fps but when going around the first alley corner the frames drop and there is micro-stutter. When using the game's default opengl everything is o.k. Another thing I noticed is that the default opengl will use both cpu cores but nGlide will only use one core.

I have disabled ATI Tray Tools, changed settings, putting Catalyst to default, etc., etc. I could have sworn everything was working great before (about 2-3 months ago) but not anymore. Before, I had 2GB memory and upgraded to 3GB but going back to 2GB did not make a difference. The only other thing I think I did was upgrade to Catalyst 14.4 from 13.1.

Other games such as Heavy Metal: FAKK 2 and Need for Speed 3 work great with a consistent 60 fps.

Anyone encounter this or any fixes out there?
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

User avatar
Zeus
Site Admin
Posts: 1472
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Kingpin and lag/micro-stutter

Postby Zeus » Mon Nov 30, 2015 1:53 am

Better check if you're using latest nGlide version.

If I recall correctly this was a problem in one of the earlier nGlide versions, but now it works fine.
Also check game directory. You may have older glide2x.dll there.

Disable compatibility mode for kingpin.exe if it's enabled.

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Kingpin and lag/micro-stutter

Postby algeeba » Sat Dec 05, 2015 12:41 am

O.k., finally had time to work on this game.

Running nGlide 1.04 (re-installed as well), compatibility mode disabled and only 3dfxgl.dll file in the directory.

Reinstalled the game and same problem with fluctuating fps. I just stand still in the first alley-way and fps fluctuate. Not sure what version the game from the cd is but I am assuming version 1.0. So both versions "1.0" and 1.21 are giving me the same problem.

If I don't use anti-aliasing and super sampling, the fps fluctuate from about 43-59. When I enable anti-aliasing and super-sampling they will fluctuate from 35-53 and, again, this is just standing still. Weird. Tried vsync, triple-buffering and nothing changed.

I could have sworn it was not doing this before.

Any ideas?

Thanks.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Kingpin and lag/micro-stutter

Postby Gamecollector » Sat Dec 05, 2015 1:34 am

The trouble is - a minigl (3dfxvgl.dll) not supports gl_ext_compiled_vertex_array and gl_ext_point_parameters.
As the example - my Ati Radeon HD3850 Agp can get 20 FPS only in Star Trek: Elite Force II w/o these extensions... And 70+ with them.
First - try the timedemo mode (kingpin +develloper 1, then timedemo 1 in the console then start the new game). If the game works ok in this mode - well, the trouble isn't the hardware.
Try this - copy an opengl ICD (3dfxvgl.dll) from latest Voodoo2 drivers to the Kingpin directory as opengl32.dll and use the default opengl in-game. This way the game will use all supported gl_extensions and will speed up.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Kingpin and lag/micro-stutter

Postby algeeba » Sat Dec 05, 2015 3:09 am

O.k. I now see where it says it does not use the gl_ext_compiled_vertex_array and gl_ext_point_parameters.

I tested the opengl ICD 1.0.0.508 (which will use nGlide) and the fps are definitely higher (70+) but the fps are fluctuating up and down about 30 fps in that alley and just standing there looking down the alley plus running down the alley there is "micro-stutter".

Using the system's opengl32.dll produces stable fps 57-63 and most of the time 59-61 fps in that same alley. But it does not use nGlide and uses both cores instead of one core using nGlide.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

User avatar
Zeus
Site Admin
Posts: 1472
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Kingpin and lag/micro-stutter

Postby Zeus » Sat Dec 05, 2015 3:16 am

Any difference after disabling VSync in nGlide configurator?

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Kingpin and lag/micro-stutter

Postby algeeba » Sat Dec 05, 2015 5:06 am

No difference at all and tried both the opengl ICD and default minigl plus disabling/enabling triple-buffering.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Kingpin and lag/micro-stutter

Postby Gamecollector » Sat Dec 05, 2015 5:22 am

By the way, how you measure the FPS value? Fraps?
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Kingpin and lag/micro-stutter

Postby algeeba » Sat Dec 05, 2015 5:54 am

Ati Tray Tools. And I did disable ATT and could tell there was micro-stuttering when moving down the alley. I can disable ATT and then measure the frames with Fraps later on if you wish.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card


Return to “Problems”

Who is online

Users browsing this forum: No registered users and 2 guests