Page 2 of 2

Re: Blade of Darkness [Severance] loading screens

Posted: Mon Dec 24, 2018 6:26 pm
by Spiros78
Ok, went back to windows 7 because of incompatibilities and delays with windows 10, and by the chance i tested to see if freeze would occur with win 7 and same hardware, and unfortunately it does occur, so it's not OS dependant.

I'd like to ask if any positive progress is done on the case and also i was wondering, after resolving another game's issue which made me think, has Nglide any software dependencies which u haven't recommended to us? Like for example vc_redist that some add-ons, mods or games need to work. I believe not but it would be good to verify that. :?: :!:

Re: Blade of Darkness [Severance] loading screens

Posted: Sun Dec 30, 2018 12:59 am
by Zeus
I just finished testing savegames you sent me.

All 3 samples work perfectly on my machine (20/20 each), I didn't have even a single freeze.
However in a debugger I noticed one issue with SmartHeap library (Bin\shw32.dll). What's even more interesting the same problem occurs also with OGL renderer, the difference is, the bug is triggered only when quitting the game and not during loading screens.

I would like to hear from you whether you see any difference with modifed library I attached below.

Spiros78 wrote:has Nglide any software dependencies which u haven't recommended to us? Like for example vc_redist that some add-ons, mods or games need to work. I believe not but it would be good to verify that. :?: :!:

There are no such requirements.

Re: Blade of Darkness [Severance] loading screens

Posted: Mon Dec 31, 2018 10:40 pm
by Spiros78
Well, once again, thanks for giving some time and thought on the issue, but despite i tested the dll u sent, freezing still occurs :roll: and i'm out of ammo.....er, i mean ideas ! ;)