NFS III HP - video problem

Report bugs, errors, problems, etc.
shupike
Posts: 2
Joined: Tue Nov 17, 2015 8:58 am

NFS III HP - video problem

Postby shupike » Tue Nov 17, 2015 9:12 am

Hello! Faced with some trouble while playing Need for Speed II: Hot Pursuit (1998). Picture quality is amasing but: I see some stick-slip motion (sorry for bad English :-) ) I'll try to explain: when I start any level in this game (Hometown, for example), it stops every 1 second. So at some moment game runs excellent, some moment - it stops. Sound is OK. Hardware configuration: Core i5 2,4 GHz, 4 Gb RAM, Video (NVidia GeForce GT740M), WIndows 7 x64. How can I fix this problem?
P.S. NFS 4 HS and NFS 5 PU are amazing, problem is only with NFS III.

Milan78
Posts: 7
Joined: Tue Sep 22, 2015 2:49 pm

Re: NFS III HP - video problem

Postby Milan78 » Tue Nov 17, 2015 11:56 am

If you want to play NFS3 without troubles then you must use VEG's patch. Here is the link: http://veg.by/en/projects/nfs3/

shupike
Posts: 2
Joined: Tue Nov 17, 2015 8:58 am

Re: NFS III HP - video problem

Postby shupike » Tue Nov 17, 2015 7:59 pm

Well, you know - same bug :? By the way - when I applied this patch, game runs without nglide (I don't see "3dfx" logo - it usually shows that nglide is active). And even in this case - same "slow motion" during all the levels in the game. May be problem with ISO?

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: NFS III HP - video problem

Postby Gamecollector » Tue Nov 17, 2015 8:16 pm

Try the attached SDB.
SingleProcAffinity and EmulateDirectDrawSync.
Attachments
NFS3.7z
(456 Bytes) Downloaded 169 times
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Milan78
Posts: 7
Joined: Tue Sep 22, 2015 2:49 pm

Re: NFS III HP - video problem

Postby Milan78 » Tue Nov 17, 2015 9:38 pm

Shupike, uninstall your game and nglide cause VEG's patch already contains newer version of it and then carefully read instructions for patch and you will be fine. Also you don't need the ACT fixes that Gamecollector gave you if you are going to use VEG's patch.

BrainRipper
Posts: 41
Joined: Fri Nov 16, 2012 11:30 am

Re: NFS III HP - video problem

Postby BrainRipper » Tue Nov 17, 2015 10:34 pm

shupike wrote:Picture quality is amasing but: I see some stick-slip motion (sorry for bad English :-) ) I'll try to explain: when I start any level in this game (Hometown, for example), it stops every 1 second. So at some moment game runs excellent, some moment - it stops.

Did you set compatibility mode "Windows 95" or "Windows 98/ME" for nfs3.exe?
If you did it remove this.

User avatar
Zeus
Site Admin
Posts: 1482
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: NFS III HP - video problem

Postby Zeus » Wed Nov 18, 2015 3:13 am

shupike wrote:Well, you know - same bug :? By the way - when I applied this patch, game runs without nglide (I don't see "3dfx" logo - it usually shows that nglide is active).

It works with nGlide but patch overrides nGlide settings. That's why you don't see it. If you want it back, modify \drivers\nglide\thrash.ini file.

shupike wrote:And even in this case - same "slow motion" during all the levels in the game. May be problem with ISO?

Most likely SingleProcAffinity is the problem. After extracting VEG's patch, open "Uninstall or change a program" from "My computer" and check for "Need For Speed 3 Patch" entry. If you have it, remove it.

If you don't, disable Windows 9x compatibility mode for nfs3.exe, like BrainRipper mentioned.


Return to “Problems”

Who is online

Users browsing this forum: ianlloyd, Magpie-Crawler [Crawler] and 1 guest