Heavy Metal FAKK 2 and 3dfxvgl problems

Report bugs, errors, problems, etc.
algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Fri Oct 02, 2015 6:49 pm

Ok, before trying anything "drastic", I decided to put the game settings to lowest detail/features and then enable/put to highest one by one and still use ATI Tray Tools.

Once I ticked on "enable GL extensions" the problem returned. With it off the game looks great. Does disabling this reduce image quality? The tweak guide says it is used to improve performance.

I did download the Catalyst 14.4 yesterday so I will try to test with those Catalyst later on today.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Sat Oct 03, 2015 12:24 am

Texture corruption is present with "enable GL extensions" ticked on and Catalyst 14.4 as well.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

User avatar
Zeus
Site Admin
Posts: 1486
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Zeus » Sat Oct 03, 2015 2:41 pm

Try to find which extension is responsible for this.

Paste this at the end of config.cfg and start disabling them one by one:
seta r_ext_compiled_vertex_array "1"
seta r_ext_compress_textures "1"
seta r_ext_gamma_control "1"
seta r_ext_multitexture "1"
seta r_ext_texture_env_add "1"
seta r_ext_texture_env_combine "1"
seta r_allowExtensions "1"

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Sat Oct 03, 2015 8:24 pm

Zeus,

r_allowExtensions "1" is the only one causing texture corruption.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

User avatar
Zeus
Site Admin
Posts: 1486
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Zeus » Sat Oct 03, 2015 8:27 pm

Did you try closing down ATT and resetting all 3D settings in Catalyst Control Center?

.. or even better restoring all settings (CCC->Preferences->Restore Factory Defaults ...)?

Gamecollector
Posts: 941
Joined: Fri Jan 07, 2011 9:29 am

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Gamecollector » Sat Oct 03, 2015 8:39 pm

It looks like he don't understood you, Zeus.
Of course if you add all these strings with "1"s and then delete them one by one - there is no result. All these extensions are enabled by default.
You must replace "1" to "0" in the 1st string, not delete it. Then run the game to check. Then return the string value to "1" and null the next one.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1486
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Zeus » Sat Oct 03, 2015 8:42 pm

Gamecollector wrote:It looks like he don't understood you, Zeus.

If that's the case he will need to repeat the test.

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Sat Oct 03, 2015 9:40 pm

Eureka! Yes, you are correct.

The extension giving the problem is "r_ext_compiled_vertex_array". Giving problems with ATI Tray Tools shut down and Catalyst and nGlide on defaults. Also giving problems with ATI Tray Tools enabled and my nGlide preferences.

In the FAKK 2 menu, turning off "Comp. Vertex Array" and leaving "enable GL extensions" on works. I must have done things backwards yesterday in the FAKK 2 menu when I disabled everything and enabled settings one by one.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

User avatar
Zeus
Site Admin
Posts: 1486
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Zeus » Sun Oct 04, 2015 1:24 am

The question now is why? You have practically the same card as me, same drivers and same game version.

And if it's not ATT I have no idea what it might be.

Do you have any other PCs near so you can compare the results?

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Sun Oct 04, 2015 3:57 am

Zeus, I don't have any other computers I could try this on.

All I can think of is trying to re-install the game or not using the no-cd executable. Do you think this would fix it? Am I losing anything by not enabling vertex array?

Thanks for your help.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card


Return to “Problems”

Who is online

Users browsing this forum: No registered users and 3 guests