Heavy Metal FAKK 2 and 3dfxvgl problems

Report bugs, errors, problems, etc.
algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Tue Sep 29, 2015 11:20 pm

Hi, I've been trying to get FAKK 2 running with nGlide 1.04 (also tried versions 1.01, 1.02 and 1.03 and have had no luck with the recommended 3dfxvgl.dll specified.

I have tried 3dfxvgl versions (only ones I could find) 438, 439 and 508. Versions 439 and 508 have really bad texture glitches throughout the game and the menu items become corrupt. Version 438 is a lot better but Julie will get texture glitches on her head and half the body at times.

Any ideas?

I really like your program and also waiting on version 1.05 so that I may also play Driver correctly.

Thanks.
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Gamecollector » Wed Sep 30, 2015 10:13 am

PC specs?
Screenshots?
Have tested with my test PC, all is ok (3dfxvgl 1.0.0.508 from the w2k 1.02.00 Voodoo2 drivers). Works ok.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Wed Sep 30, 2015 4:38 pm

Hi,

WinXP SP3, Opteron 185 (overclocked), 2 GB memory, HD 5870 Catalyst 13.1

Attached are screenshots with the 508, 438. Lettering in the menu using 438 also looks weird when accessing the video/audio/advanced. Let me know if you need a screenshot of that. I also tried the WickedGL opengl32 and seems to work fine but anti-aliasing does not work.

Thank you very much for your help.
Attachments
3dfxvgl 508 FAKK 2.jpg
3dfxvgl 508 FAKK 2.jpg (151.14 KiB) Viewed 2705 times
3dfxvgl 508 FAKK 2 Menu.JPG
3dfxvgl 508 FAKK 2 Menu.JPG (58.39 KiB) Viewed 2705 times
3dfxvgl 438  FAKK 2.jpg
3dfxvgl 438 FAKK 2.jpg (175.76 KiB) Viewed 2705 times
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

User avatar
Zeus
Site Admin
Posts: 1476
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Zeus » Wed Sep 30, 2015 5:14 pm

Tried 3dfxvgl from nGlide compatibility list?

What's your game version?

Post your cfg files from \fakk subfolder.

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Wed Sep 30, 2015 7:52 pm

Zeus,

yes, the 508 version I am using is from your compatibility list and my game version is 1.02. I am using a nocd executable.

I do have customwidth and customheight in the config file but I get the same results without them. I set "r_gldriver 3dfxvgl.dll" in the console and renamed the .dll to "opengl32" with the same results. I use AtiTrayTools to set my game parameters (anti-aliasing, etc..) but get the same results by disabling AtiTrayTools.

I have also tried nGlide version from 1.04 to 1.01 and have deleted the config file so that the game could create a new one and still the same problem.
Attachments
nGlide.JPG
nGlide.JPG (19.92 KiB) Viewed 2699 times
config.JPG
config.JPG (145.95 KiB) Viewed 2699 times
autoexec.JPG
autoexec.JPG (109.21 KiB) Viewed 2699 times
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Gamecollector » Wed Sep 30, 2015 8:44 pm

Hmm... If there is the "Catalyst AI" option in your Catalyst - try "Disabled" then "Basic".
About Ati Tray Tools - some settings can break nGlide. So - try the clean Catalyst install.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

algeeba
Posts: 15
Joined: Tue Sep 29, 2015 11:12 pm

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby algeeba » Wed Sep 30, 2015 11:44 pm

No dice on the Ati Tray Tools settings plus I tried disabling others. Also looked at the FAKK 2 console and noticed some things so I got my tweak guide and tried some changes, such as multi-texture and texture compression, but no change.

Another thing I noticed on the console is something about calling opengl32.dll in windows/system32. Is this right? Attached is a jpg of the console.

As I am downloading a game from Steam at the moment, I will try another Catalyst version, such as the 12.3 that you have Gamecollector.
Attachments
FAKK 2 Console.JPG
FAKK 2 Console.JPG (148.48 KiB) Viewed 2686 times
XP Pro SP3/overclocked Opteron 185/3 GB DDR 400
DFI LAN Party NF 4
HD 5870 PCIE, Catalyst 14.4
X-FI Xtreme Music Sound Card

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Gamecollector » Thu Oct 01, 2015 11:04 am

No, it's different...

HMF2.JPG
HMF2.JPG (60.42 KiB) Viewed 2675 times

1.02 version... "Video/Audio"/"Advanced"/"OpenGL driver" is 3dfxvgl or something different?
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1476
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Zeus » Thu Oct 01, 2015 2:42 pm

algeeba wrote:Zeus, yes, the 508 version I am using is from your compatibility list

Keep using this file and don't rename it to opengl32.

algeeba wrote:I use AtiTrayTools to set my game parameters (anti-aliasing, etc..) but get the same results by disabling AtiTrayTools.

Disable/uninstall it until we find the solution. Reset all your 3d settings in Catalyst Panel (Default button) and set nGlide configurator settings to their defaults. Make sure you're using nGlide 1.04.

Try different Catalyst drivers. I currently use 14.4 (previously 12.3) and never had a problem like this (my Radeon is HD 5670).
So far I wasn't able to replicate the issue (tried to change tons of config settings / display driver settings). I even installed ATT (which I normally don't use), changed a lot of its settings, but still no dice.

Gamecollector
Posts: 940
Joined: Fri Jan 07, 2011 9:29 am

Re: Heavy Metal FAKK 2 and 3dfxvgl problems

Postby Gamecollector » Thu Oct 01, 2015 3:35 pm

By the way if you use 1.01 or 1.02 versions - you not need the console to force 3dfxvgl.dll. You can change the open gl driver in the "Video/Audio"/"Advanced" menu. Same as Daikatana.
Asus P4P800 SE/Pentium4 3.2E/2 Gb DDR400 (3-3-3-8),
Radeon HD3850 Agp (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).


Return to “Problems”

Who is online

Users browsing this forum: No registered users and 4 guests