Page 1 of 2

Need For Speed II SE

Posted: Sat Mar 07, 2015 2:40 pm
by Durrsly
A few days ago I got Need For Speed II SE at a local thrift store. I installed it in Windows 95 Compatibility mode then installed nGlide. The problem is that nGlide doesn't seem to detect the game and it runs at 640x480 regardless of my settings. It also runs very slowly, but I don't think that's an nGlide issue. I did install the patch on the compatibility list, but that was after I installed everything else.

OS: Windows Vista 32-bit
Video card: Nvidia 750Ti
nGlide version: 1.04

Re: Need For Speed II SE

Posted: Sat Mar 07, 2015 2:43 pm
by Zeus
Are you launching the game with NFS2SEN.EXE? You need to run it with NFS2SEA.EXE (copy it from a CD if it's not present in the game dir).

Re: Need For Speed II SE

Posted: Sat Mar 07, 2015 2:59 pm
by Durrsly
That fixed the resolution but the game runs very slowly in game. Pausing via the escape key makes the game run smoothly, but when I unpause the game it goes back to being slow.

Re: Need For Speed II SE

Posted: Sat Mar 07, 2015 3:21 pm
by Zeus
There are 2 patches in the zip. One for playing the game and one for videos. If you installed both uninstall video patch and try to run the game again. Also make sure NFS2SEA.EXE has no compatibility modes set.

Re: Need For Speed II SE

Posted: Sat Mar 07, 2015 3:27 pm
by Durrsly
I only installed the one for the game, and if I don't have a compatibility mode set it gets stuck on a black screen after the 3Dfx logo.

Re: Need For Speed II SE

Posted: Sat Mar 07, 2015 3:38 pm
by Zeus
Try this scenario then:
-disable W95 compat mode for NFS2SEA
-uninstall game patch
-install video patch.

Re: Need For Speed II SE

Posted: Sat Mar 07, 2015 4:01 pm
by Durrsly
That fixed it, thanks!

Re: Need For Speed II SE

Posted: Wed Apr 08, 2015 9:56 pm
by Sammy75
It works also well with Virtualbox+3D Addon with Windows XP and Nglide.

Re: Need For Speed II SE

Posted: Mon Apr 27, 2015 11:57 am
by DVV
Found a working solution for clear sound in NFS 2 SE!!!
Verified it under Windows 7 32-bit (desktop PC) and Windows 8.1 64-bit (laptop). And it does not depend on your sound card!
The solution is:
1. Place dsound.dll (taken from Windows XP) directly into your NFS 2 SE folder (where the game was installed to).
2. Run NFS2SEA.EXE as administrator.
3. Enjoy the game!
The explanation:
- NFS 2 SE seems to rely on sound processing provided by dsound.dll from Windows XP, whereas dsound.dll from newer systems are not completely OK for the game.
- running as administrator is required for the game to pick up dsound.dll from its current folder instead of the system's one. Though, first you can try without the administrator rights - maybe it work under 64-bit system. But under Windows 7 32-bit I definitely needed to run it with administrator rights.

Re: Need For Speed II SE

Posted: Tue Jun 14, 2016 7:25 am
by Sammy75
I have a fresh install of windows xp prof with SP3.

It's a AMD X2 6000 CPU.

I installed nglide 1.05.

NFS2SE runs, but sometimes a little to fast..

So i think it has maybe Problems with DualCore cpus?

I disabled the second core with /numproc=1 in boot.ini

Now the Menue of NFS2 is at normal speed, but the Race is at slowmotion.
Feels like 1 second in Game is 3 till 5 seconds in realtime.

Does nglide (1.05) need more than one Core?
Or is it an issue that i disabled the sencond core?