Powerslide Texture buggin with NGlide

Report bugs, errors, problems, etc.
IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: Powerslide Texture buggin with NGlide

Postby IceMan » Mon Jan 19, 2015 4:23 pm

I tried Powerslide last night, needed nopollsound fix in ps_clo.exe, plus setting as WinXP compatibility once to get the game to boot, then (as per other games) I can remove the compatibility and the game still works (odd, or a Win8.1 feature?). I'm using patched version 1.04.

Anyway, in-game, using either Glide, or forcing Glide2 in ps_clo.exe, the polygons are all breaking up, warping, wrapping, strobing, etc. The same happens (but a bit less) when using the latest dgVoodoo scaling test WIP version from VOGONS.

I've not played with Direct3D much yet, as by default that crashes, so I need to try dgVoodoo's DX wrapper, however any idea why Glide is being so mental?

I'll put up pics later, it looks like a badly emulated arcade game!
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor

IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: Powerslide Texture buggin with NGlide

Postby IceMan » Mon Jan 19, 2015 7:57 pm

Image

Bit crazy (sorry did 640x480 res!). I'm going to have a little play around with the options and test the game with 1.00, 1.01 and 1.04 patches.

I tried taking screenshot of dgVoodoo, which has some corruption but not as bad, but it crashed the game when I tried taking a screenshot.

Software mode seems okay, but Direct3D won't really work at all.
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor

IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: Powerslide Texture buggin with NGlide

Postby IceMan » Mon Jan 19, 2015 8:31 pm

Tried 1.00 and 1.01 but both kept saying it wouldn't work on NT, even with compatibility mode swapped, only 1.04 works for me now :-/
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor

IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: Powerslide Texture buggin with NGlide

Postby IceMan » Thu Apr 30, 2015 11:50 pm

Does anyone else get anything like this in nGlide? Still happens in nGlide 1.04 (for patched version 1.04 of the game).
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor

User avatar
Zeus
Site Admin
Posts: 1473
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Powerslide Texture buggin with NGlide

Postby Zeus » Fri May 01, 2015 12:02 pm

IceMan wrote:Tried 1.00 and 1.01 but both kept saying it wouldn't work on NT, even with compatibility mode swapped, only 1.04 works for me now :-/

For me 1.00 works fine on Windows 8.1.
Powerslide.exe (crc32: 5FF2300E) + GeForce GTS 450. No compatibility modes.

IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: Powerslide Texture buggin with NGlide

Postby IceMan » Tue May 05, 2015 12:27 am

I believe the later patches added and improved a few things, any idea why they behave so weird in nGlide? I can try down-patching again at some point...
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor

User avatar
Zeus
Site Admin
Posts: 1473
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Powerslide Texture buggin with NGlide

Postby Zeus » Tue May 05, 2015 10:23 pm

1.01+ feeds Glide API with incorrect vertex data. I need to find a better approach to tackle this.

This means right now using 1.00 version is the only way to play the game without any glitches.

IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: Powerslide Texture buggin with NGlide

Postby IceMan » Wed May 06, 2015 12:18 am

I just had another go at this; the original GT Interactive UK/Euro version I have just won't start without being version 1.04, it keep saying it won't run on NT, and either compatibility mode or Win95 version lie ACT fixes do nothing :-/
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor

IceMan
Posts: 95
Joined: Thu Nov 19, 2009 10:32 pm

Re: Powerslide Texture buggin with NGlide

Postby IceMan » Wed May 06, 2015 12:42 am

Just for the sake of completeness: Zeckensack's wrapper = totally messed up polygons, can't see anything!
dgVoodoo = marginally better than nGlide, but still vanishing vertexes throughout.

I've been unable to force Direct3D at any point though, to check that, as the game won't seem to boot at all without using a Glide wrapper!

I wonder what the GOG version does/has?
My PC spec: Win8.1, i7-4970K (not overclocked) MSI Nvidia GeForce GTX 980, Creative Soundblaster ZX, 16GB RAM, Asus Z98-A motherboard, ROG Swift GSYNC monitor


Return to “Problems”

Who is online

Users browsing this forum: No registered users and 2 guests