NGlide versus my glide games collection

Report bugs, errors, problems, etc.
Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: NGlide versus my glide games collection

Postby Gamecollector » Sat Jan 09, 2016 1:04 pm

Done.
Can't repeat this "no 3dfxspl.dll" glitch. It looks like the cause was "any PC needs at least 1 reset in a week"...

P.S. I will resume the testing after the holidays...
Attachments
Time Warriors exes.7z
(710.46 KiB) Downloaded 283 times
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1563
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: NGlide versus my glide games collection

Postby Zeus » Tue Jan 12, 2016 2:28 am

I fixed a wrong background glitch in 2x version of Time Warriors, but I can reproduce problems with 1x version. Both nGlide versions (1.03/1.04) work ok for me. I don't know, maybe send me your wartim.def.

I also can't reproduce crash in unpatched F22L3 (1.00.00.02).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: NGlide versus my glide games collection

Postby Gamecollector » Tue Jan 12, 2016 12:31 pm

Well, I hope I will finish the winglide list (22 titles) in this week (Holidays are almost over, only the Old New Year isn't passed).
Then I will retest all founded bugs again. On my test PC and on both notebooks. And maybe in Vista too...
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1563
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: NGlide versus my glide games collection

Postby Zeus » Tue Jan 12, 2016 8:40 pm

Gamecollector wrote:I will retest all founded bugs again.

Just retest these two I cannot reproduce. No need to retest all of them.

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: NGlide versus my glide games collection

Postby Gamecollector » Fri Jan 15, 2016 2:46 am

Ultima IX: Ascension - a cursor in movies is fixed.

Uprising 2: Lead and Destroy - wrong pixel centering is fixed.

Uprising: Join or Die - still crashes after quitting (module glide2x.dll offset 5cec). Have started New Campaign (Erudara mission), have played around 1 minute, then - Esc, Exit, Options, Exit, Main Menu, Quit.
1 graphicsl bug - artefacts in the HP bar area after some time (if HPs arent full). If I select satellite view or external view - the bug is gone.
P.S. It looks like the game not like nGlide at all. Priva mission, ctd (nt.dll offset 36822) if I build something.
Of course my Voodoo2 SLI works ok w/o these bugs...
*Censored*.
Attachments
Uprising1.JPG
Uprising1.JPG (33.5 KiB) Viewed 4208 times
Last edited by Gamecollector on Fri Jan 15, 2016 8:10 pm, edited 9 times in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1563
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: NGlide versus my glide games collection

Postby Zeus » Fri Jan 15, 2016 3:30 pm

Third issue I cannot reproduce: Wrong texturing in CS and Gunman with default OpenGL + 3dfxvgl 1.0.0.439.

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: NGlide versus my glide games collection

Postby Gamecollector » Fri Jan 15, 2016 6:18 pm

Zeus wrote:Third issue I cannot reproduce: Wrong texturing in CS and Gunman with default OpenGL + 3dfxvgl 1.0.0.439.

I not used the default opengl. "3Dfx OpenGL for Voodoo 1, 2 & Rush" was choosed in the left pull-down list.
Have tested CS again (and have renamed 3dfxvgl.dll in %system%\system32 to be sure), the bug is here. Just at the start of "Training" as the example...
P.S. Well, even if I rename 3dfxvgl.dll to opengl32.dll and use "default opengl" - the bug is still here on my test PC.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: NGlide versus my glide games collection

Postby Gamecollector » Fri Jan 15, 2016 11:11 pm

V-Rally: Multiplayer Championship Edition - car shadows are ok now.

Vigilance - unpatched version can restart w/o any errors now.
By the way, this game "have" 3dfx 320x240 mode. Both Voodoo2 SLI and nGlide set this mode as "1024x768 with the 320x240 draw area in the top left corner"...

Warzone 2100 - still broken.
Attachments
Warzone2100.JPG
Warzone2100.JPG (5.48 KiB) Viewed 4197 times
Last edited by Gamecollector on Sat Jan 16, 2016 12:17 am, edited 2 times in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1563
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: NGlide versus my glide games collection

Postby Zeus » Sat Jan 16, 2016 12:08 am

Gamecollector wrote:Have tested CS again (and have renamed 3dfxvgl.dll in %system%\system32 to be sure), the bug is here.

Fixed. My bad, I was copying wrong file.

Gamecollector wrote:Vigilance - unpatched version can restart w/o any errors now.

Are you sure? Some guy told me he had this bug even with 1.04, but I can't reproduce it on my PC.

Where was this error with 1.03? Screenshot?

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: NGlide versus my glide games collection

Postby Gamecollector » Sat Jan 16, 2016 12:33 am

Zeus wrote:Are you sure? Some guy told me he had this bug even with 1.04, but I can't reproduce it on my PC.
Where was this error with 1.03? Screenshot?

Start a new game ("Begin New Game" etc), nGlide starts (3dfx logo).
Exit to the main menu ("Abort Mission").
Start a new game again, the game quits to the desktop with these 2 popups:

Vigilance1.JPG
Vigilance1.JPG (5.27 KiB) Viewed 4196 times
Vigilance2.JPG
Vigilance2.JPG (6.26 KiB) Viewed 4196 times

Nglide 1.04 is ok, 5 "new mission"/"abort mission" cycles - no crash.
P.S. Only Vigilance 1.0 was affected.
Last edited by Gamecollector on Sat Jan 16, 2016 12:38 am, edited 1 time in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).


Return to “Problems”

Who is online

Users browsing this forum: Bing [Bot] and 7 guests