Page 1 of 2

My list of issues

Posted: Thu Jul 22, 2010 11:38 pm
by RazTK
Hello and thank you for this great wrapper!

1. There's a minor issue in Rayman 2, where if you set the resolution via the in-game menu (Options -> Video) the game crashes. I know, a minor thing (or not?), but I thought I'd report it in. Anything to make this wrapper a little more stable. :)

2. In POD Gold, the game crashes with a 'grSstWinOpen' error right before it starts to play the intro (after the Ubi Soft and Intel MMX logos). It's possible to fix this by deleting the Indeo codecs ('ir32_32.dll' and 'ir41_32.dll') from the Windows folder, but it'd be great to see it properly fixed.

My system specs:
AMD Athlon 64 X2 4400+
GeForce 9600GT 1GB
2GB of RAM
Windows XP SP3

Thanks again and keep doing a great job!

Re: Rayman 2 and POD Gold crashes

Posted: Fri Jul 23, 2010 9:50 am
by Zeus
Thanks for your support. :)

Re: My list of issues

Posted: Sun Jul 25, 2010 2:14 am
by RazTK
I figured it'd be fine if I post in this thread instead of opening a new one.

I've been playing Carmageddon 2 lately, and I've come across the following issues:

1. If I set a higher resolution in the configurator (1280x1024, to be specific), it's possible for the mouse to "get lost" through the right and bottom sides of the screen. What I mean is, if I move the cursor to the bottom or right side of the game's menu, I can still keep moving the mouse and it'd keep moving as if I didn't reach the end of screen (although the cursor is still seen). I know, it sounds confusing (sorry), but I'm sure you'll see what I mean once you test it by yourself.

2. While viewing the map during a race, the shadow beneath your car will flicker once you drive fast enough (and yes, VSync is enabled in the drivers). This doesn't seem to happen with dgVoodoo.

That's about it for now. :>

Re: My list of issues

Posted: Sun Jul 25, 2010 4:02 pm
by Zeus
mouse to "get lost"


While viewing the map during a race, the shadow beneath your car will flicker


Both can't be fixed. These are game coding bugs (sort of) so occur with other wrappers as well.

Re: My list of issues

Posted: Sun Jul 25, 2010 7:53 pm
by RazTK
Well, for the second issue, it's really not as bad (if noticed at all) as in nGlide (I've compared with dgVoodoo v1.40+, BTW). But, it really is a minor issue ('issue' isn't even an appropriate word... more like a nitpick :>) that doesn't affect the gameplay at all. Thanks for looking into it though!

Re: My list of issues

Posted: Mon Jul 26, 2010 12:47 pm
by Toshiba-3
For your first issue, install the latest patch (super patch v2) and it should fix that mouse in a box problem.
You can get it there http://rr2000.toshiba-3.com under PC TOOLS. (it's the UK Blood patch but should work with any version)
If you installed addon cars/tracks backup the OPPONENT.TXT and RACES.TXT files.

Re: My list of issues

Posted: Mon Jul 26, 2010 2:53 pm
by RazTK
Toshiba-3
Thank you for trying to help, but if you'll read my post again more carefully, you'll see that that's not what I'm talking about. :> And while we're talking about C2, do you get any CD music with the "Super Patch"? I don't. I only get it with the "XP/Vista Patch" (as people call it).

Re: My list of issues

Posted: Wed Jul 28, 2010 12:15 pm
by Toshiba-3
Ah I read too fast :-/... And actually I have that mouse getting lost issue as well. Really minor issue indeed.
And no, no CD playback with the cracked Super Patch here, might want to try a genuine super patch v2 then?
I only have the original C2 cd for Mac so can't test under Windows. You can find the original C2 patches there: http://rr2000.toshiba-3.com/R4/PC/Patches
And here's a bit I wrote about the C2 patches if you're interested.

Re: My list of issues

Posted: Wed Jul 28, 2010 1:33 pm
by RazTK
Okay, the only patch that seems to have CD music is the "XP/ Vista" one. So, with all due respect to the "Super Patch", C2 without the CD music isn't the same C2. :>

Oh, and I did read your article about the patches. Very interesting reading!

Re: My list of issues

Posted: Thu Jul 29, 2010 12:58 pm
by Toshiba-3
Most people in the Carmageddon community let music players running in the background, I even tend to run C2 with no sound at all... no wonder why we didn't really pay attention to the lack of CD playback! That's a serious bummer though. No idea how to bring this back :(

Updated the article about patches accordingly. Thanks for the heads-up btw :)