carmageddon 1 inside gulikoza dosbox issues

Report bugs, errors, problems, etc.
colossus
Posts: 3
Joined: Wed Jul 07, 2010 11:17 pm

carmageddon 1 inside gulikoza dosbox issues

Postby colossus » Wed Jul 07, 2010 11:27 pm

hi,

many thanks for creating this new glide wrapper, i think its brilliant!

i have a problem with using the latest version 0.93 of nglide with gulikoza's compiled dosbox with glide support.

carma 1 loads up, the 3dfx logo displays (sometimes twice, one after the other) and then i get a fullscreen of blackness and nothing else. i can hear the sound of the intro but its very choppy.

i then start a new game by just pressing enter basically to say ok to all the menus even tho i have a black screen. it then loads the game and i can play it. the audio is massively choppy and the game seems slower then when using dgvoodoo - with no audio choppyness. when i press escape i can get the menu up and it displays fine but it isnt displayed at the beginning of the game when it loads, just a black screen!

can you help with the choppy audio and the black screen?

thanks very much,

col.

User avatar
Zeus
Site Admin
Posts: 1562
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: carmageddon 1 inside gulikoza dosbox issues

Postby Zeus » Thu Jul 08, 2010 4:44 pm

What's your CPU and graphics card?

colossus
Posts: 3
Joined: Wed Jul 07, 2010 11:17 pm

Re: carmageddon 1 inside gulikoza dosbox issues

Postby colossus » Thu Jul 08, 2010 6:30 pm

hi,

cpu: intel core 2 quad q6600

gfx: nvidia geforce 8800 gts 512mb
driver version: 190.38

User avatar
Zeus
Site Admin
Posts: 1562
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: carmageddon 1 inside gulikoza dosbox issues

Postby Zeus » Sat Jul 10, 2010 11:25 pm

Hmm.. strange..

Did you tried CosmicDan compilation too? (see FAQ if not). What are the results?
You may also try to re-download and re-install nGlide 0.93.

colossus
Posts: 3
Joined: Wed Jul 07, 2010 11:17 pm

Re: carmageddon 1 inside gulikoza dosbox issues

Postby colossus » Mon Jul 12, 2010 2:31 pm

Hi,

thanks for the suggestion.

I can confirm that the CosmicDan version of dosbox works fine.

no idea why gulikoza build doesnt work with nglide but hey, its working thats the main thing!

cheers.

Latvian3Dman
Posts: 4
Joined: Sat Sep 18, 2010 8:58 pm

Re: carmageddon 1 inside gulikoza dosbox issues

Postby Latvian3Dman » Sat Sep 18, 2010 9:14 pm

Hello!
I must say, i am kinda new into both nGlide and DOSbox, i think i read carefully how it can be done for carmageddon1, but i am not getting 3Dfx mode. Would anybody please help me what i am doing wrong? I will post here in much details what i have done:
Unpacked dosbox-2010-03-22-custom-glide.zip ;
in that folder i have now two additional folders:
CARMAMAX - with carmageddon .cue and .bin files,
INTRPLAY\GAMES\CARMA - with game files, including 3DFX.exe 1 386 906 bytes.
I added in dosbox.conf at the end:

@echo off
mount C intrplay
imgmount D "CARMAMAX\Carmageddon.cue" -t iso
c:
cd \games\carma\
3dfx
exit

Of course i have nGlide 0.93 installed. I have Directx9 graphic card GeForce 7800GT.
I run dosbox.exe
I got game running (3dfx.exe) windowed in software mode, no 3dfx logo too. I can Alt-Enter to fullscreen, the same software rendering. At that time DOSbox Status Windows says: grSstWinOpen failed!

Could anyone please point to my mistake, what i do wrong?
Thank You in advance!

User avatar
Zeus
Site Admin
Posts: 1562
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: carmageddon 1 inside gulikoza dosbox issues

Postby Zeus » Sun Sep 19, 2010 12:10 am

You've done nothing wrong, but there shouldn't be grSstWinOpen failed message.

First idea is to download and reinstall DirectX from Microsoft website. Also check the filesize of nGlide's glide2x.dll in your \windows\system32\ directory (if you have 32-bit windows) or \windows\syswow64\ (for 64-bit). Glide2x.dll filesize should be 1273856 bytes. There shouldn't be any other glide2x.dll (not nGlide's) in the the dosbox directory.

BTW, what's your OS?

Latvian3Dman
Posts: 4
Joined: Sat Sep 18, 2010 8:58 pm

Re: carmageddon 1 inside gulikoza dosbox issues

Postby Latvian3Dman » Sun Sep 19, 2010 8:01 am

Thank You, Zeus. I was pretty sure i have latest dx9c and latest geforce drivers, but i reinstalled both and i really have some progress here: windows game (Turok) now works perfect, and in Carma1 case i got 3Dfx logo 2 times, then black screen with sound (sound with hickups). I dont have dual monitors, as was the case for someone in this forum, that caused black screen.
I have WindowsXP Pro SP3, glide2x.dll is 1 273 856 bytes. I wonder, with what i could experiment more to get Carma1 working... :)
In any case - thank you for your great work on nGlide! Back when first 3Dfx Voodoo came out, what a shocking joy it was. Your nGlide helps to refresh those emotions :)

User avatar
Zeus
Site Admin
Posts: 1562
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: carmageddon 1 inside gulikoza dosbox issues

Postby Zeus » Sun Sep 19, 2010 1:23 pm

Try re-download dosbox (CosmicDan's compilation). Make sure you haven't modified any sections in dosbox.conf (except autoexec). Try Gulikoza's compilation too. You can also try to install other versions of Nvidia drivers. You don't have two monitors but maybe it's not about to have it physically. Maybe dual-monitor option must be disabled in the drivers panel?

If you find the solution please post it here.

Latvian3Dman
Posts: 4
Joined: Sat Sep 18, 2010 8:58 pm

Re: carmageddon 1 inside gulikoza dosbox issues

Postby Latvian3Dman » Mon Sep 20, 2010 6:12 pm

Somehow i got Carma1 working now. I deleted CosmiDan's build, downloaded Gulikoza's build from his page, deleted Glide2x.dll from there, and - Carmageddon worked in 3Dfx mode. Interesting note maybe: before i was getting that big 3Dfx logo at start (2 times), now i have that smaller one with star-explosion background thingie.
Even more interesting, then i deleted all Gulikozas build, unpacked CosmiDans build, and - now it works too!
Still, framerate is low, but my PC isnt great either, it is oldish one core Athlon 1800+. Sond stutters too.


Return to “Problems”

Who is online

Users browsing this forum: No registered users and 8 guests