Page 31 of 34

Re: Nglide with ATi legacy cards

Posted: Thu Nov 28, 2013 10:17 pm
by Gamecollector
Scorched Planet - I'm not sure, but this looks like nGlide's glide.dll glitch. "HI" after the "Resolution" string is garbled.

Serious Sam - there is a big trouble, the game start a 3dfx mode with the nGlide only once. Then no 3dfx logo at the start. "OGL context can't be created"... Have tested this with my retroPC and my notebook.
A real Voodoo2 is working perfectly.
3dfxvgl.dll is from W2k 1.02.00 Voodoo2 drivers.
P.S. nGlide 1.01 - same trouble. WtF, I have tested this game several months ago with the same 3dfxvgl.dll and this problem wasn't here... :(

Re: Nglide with ATi legacy cards

Posted: Fri Nov 29, 2013 12:24 am
by Gamecollector
Serious Sam: the Second Encounter - the rendering is ok on my notebook with a GF 9500M GS videocard.
There is trouble with the ATi videocard (Radeon HD2600 Pro Agp): z-fighting.
Broken "Players and Controls" screen with all GPUs.
A Real Voodoo2 is freezing sometimes. Known Serious Sam glitch...

Re: Nglide with ATi legacy cards

Posted: Mon Dec 02, 2013 7:47 am
by Gamecollector
Star Trek: Elite Force II - the rendering is ok on a NVidia videocard and broken on an ATi.
There is also a ctd (glide3x.dll offset 6b13) (1st mission, shoot the 1st power grid).
You must set "Flares"=precise to get these two errors. The trouble is - a real Voodoo2 is working perfectly with this option.

Star Trek: Voyager - Elite Force - unpatched version: texturing errors and game freezes with "Texture detail"=very high.
Patch 1.2 - ctd (glide3x.dll offset 6b13) at the level loading (again if "Texture detail"=very high).

Re: Nglide with ATi legacy cards

Posted: Tue Dec 03, 2013 10:37 pm
by Gamecollector
Starshot - I've tried several times but haven't forced the "only sound in the intro" glitch. So - this entry is removed.
Starsiege and Starsiege: Tribes - voices and FX are missed/disappeared sometimes. AFAIR this is known Windows/Wine glitch but I can't remember a solution...
By the way, there is no text blinking in Spec Ops II: U.S. Army Green Berets with the Catalyst 12.3. So - at last this entry is removed...

Re: Nglide with ATi legacy cards

Posted: Mon Dec 09, 2013 12:28 am
by Zeus
Gamecollector wrote:Scorched Planet - I'm not sure, but this looks like nGlide's glide.dll glitch. "HI" after the "Resolution" string is garbled.
Well, it's not.

Re: Nglide with ATi legacy cards

Posted: Wed Dec 11, 2013 12:54 am
by Zeus
Gamecollector wrote:Star Trek: Voyager - Elite Force - unpatched version: texturing errors and game freezes with "Texture detail"=very high.
Patch 1.2 - ctd (glide3x.dll offset 6b13) at the level loading (again if "Texture detail"=very high).
I can't replicate any of the bugs. Can you send me your efconfig.cfg?

Re: Nglide with ATi legacy cards

Posted: Wed Dec 11, 2013 8:58 am
by Gamecollector
Have retested Star Trek: Voyager: Elite Force with all Voodoo2 drivers removed and nGlide 1.02 re-installed.
Now it's like Serious Sam: 2nd Encounter and Star Trek: Elite Force II. No visual glitches with a real Voodoo2 and NVidia, glitches with ATi (z-fighting).
Efconfig.cfg is attached.
3dfxvgl.dll is from Voodoo2 W2k 1.02.00 drivers (crc32 0d1f5c59).
IIRC the only difference is r_picmip="0" with "Texture detail"=very high.

P.S. *Censored*. The error is still here even with "Texture Detail"=high. :(
Maybe the source is ATi Catalyst... - no, Catalyst 12.4 haven't changed anything. Serious Sam use nglide only once. Wrong rendering in Serious Sam 2nd Encounter, Star Trek: Elite Force II and Star Trek: Voyager - Elite Force... :(

Re: Nglide with ATi legacy cards

Posted: Sat Dec 21, 2013 5:36 pm
by Gamecollector
Ok, I resumed the nGlide 1.02 testing at last... 36 titles to go, approximately 1 week to finish.

Tiger Woods 99 PGA Tour Golf - the drawing is ok now. Loading cursor's blinking is on a real Voodoo2 too.
A loading time is still very long even with "Vertical synchronization"=off. It looks like the cause for the slowing is loading cursor drawing only.
Picture in Picture mode is slow too.

Tiger Woods PGA Tour 2001 - ctd (~def8ee.tmp offset ec09). Even with the software renderer. *Censored*. I will try to find the source of this error.
P.S. Yes, the game is working on my notebook. Oh, well...

P.S.S. Have fixed this error. Bad system32\drivers\secdrv.sys.

Same troubles as with TW99 - long loading times and slow Picture-in-Picture. Loading cursor's traces are fixed.
Plus - there is another strange nGlide behavior. When you left click - the arc destination/putt marker move to the cursor. The orientation is right but the distance is always maximum with nGlide: http://www.4shared.com/video/THZ4fbhs/TW2001.html.
P.S.S.S. TW99 have this pointing trouble too. A real Voodoo2 or D3d/software renderer are working ok.
Glide3x renderer - no fog (nGlide and a real Voodoo2).
NGlide is ctd with the glide2x renderer after quitting. Offset is 584d. A real Voodoo2 is working ok.

Tigershark - heh, original version is the glide 2.1.1 game... Have found this only now.

Time Warriors - there is the 2nd executable (_st_3dfx0.exe) which uses glide 2.1.1.

Total Annihilation: Kingdoms - nGlide 1.02 isn't detected by chooserenderer.exe. Version 1.01 is working ok.

Total Soccer 2000 - goal's textures aren't drawn fully.

Re: Nglide with ATi legacy cards

Posted: Tue Dec 24, 2013 9:28 am
by Gamecollector
Triple Play 99 - textures' shifting is the game "feature".
Models are missing sometimes when the pitcher made a throw.
Have found a reason for the original version freeze. Original version isn't working with EmulateDirectDrawSync+nGlide. Patched version isn't working w/o EmulateDirectDrawSync+nGlide...

Turok 2: Seeds of Evil - ctd after the in-game's "quit to Windows" (video_3dfx.dll offset 7c32). Voodoo2 is working ok. I have attached the errorlog.txt.

Re: Nglide with ATi legacy cards

Posted: Sat Dec 28, 2013 4:12 am
by Gamecollector
Ultimate Hunt Challenge now is working with glide2x renderer. But there is no 3dfx logo before a simulation. So maybe this is the cause for this. :)
Unfortunatedly these 3 games are freezing with a real Voodoo2... Main menu is working ok but the game itself - blank screen...
P.S. Strange but a real Voodoo2 is working after I have started these games with nGlide's glide2x/3x.dll once. But the freeze is returning after a reboot. WtF?

Uprising 2: Lead and Destroy - there is a little visual glitch with buttons and target's healthbars in this game. Upper-left and lower-right button's corners.
P.S. Gulf War: Operation Desert Hammer - same glitch...