Nglide with ATi legacy cards

Report bugs, errors, problems, etc.
Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Sun Aug 14, 2011 7:40 am

robertmo wrote:
Battlecruiser 3000 AD 2.0 - X. DOSBox incompatibility. The game freezes after the "new game" was selected.

I think 2.x are windows versions. Dos versions were 1.x
Though I have some 2.0 3dfx preview patch that works in DOS...

No. This is DOS game with Win9x only installer. So, just install the game in Windows, mount the game dir in DOSBox and edit patches in bc3000.ini. Another example of this - Redguard 3dfx.

Dreams of Reality. Small glitches (text blinling, shadows).

"real shadows" option is not available with dreamsfx.exe on my Pentium 166MMX with real Voodoo1 4MB card too. (btw this game doesn't work with voodoo2 (haven't found any patch for that) )

No, the 2d shadows are incorrect. The link was added.

Jetfighter: Full Burn

if you start training and press * for switching views you will notice water on the ship.
It is a nglide problem most probably because:
With real voodoo1 and voodoo2 cards it is only a small stripe of water error. Real computer behaves like dosboxglide+real voodo (small stripe water error too).

Added. Tnx.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

robertmo
Posts: 65
Joined: Tue Jul 26, 2011 3:41 pm

Re: Nglide with ATi legacy cards.

Postby robertmo » Sun Aug 14, 2011 8:55 am

shadows and air bubbles in Dreams look ok here.
Also i only have vertical lines with redguard/xcar/burnout when i upscale resolution in nglide (if i use default it is ok)
I have geforce 285gtx

Ok, several DOS glide games had been tested with this build

what games needed cosmic build?
Last edited by robertmo on Wed Aug 17, 2011 7:52 am, edited 1 time in total.

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Sun Aug 14, 2011 10:19 am

robertmo wrote:I have geforce 285gtx

Yeah, this topic is for unhappy and cursed Radeon X series owners. Like me. Of course you don't have 99% of the artifacts and glitches. For Dreams to Reality - it looks like ATi glitch.
Tomorrow I retest DOSGlide list with Radeon HD 5730.
Last edited by Gamecollector on Tue Aug 16, 2011 10:39 am, edited 2 times in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

robertmo
Posts: 65
Joined: Tue Jul 26, 2011 3:41 pm

Re: Nglide with ATi legacy cards.

Postby robertmo » Mon Aug 15, 2011 11:02 am

Battlecruiser 3000 AD 2.09 Freeware C:\BC3000AD\BC3KFAQ.HTML
Q. WHY WON'T THE GAME RUN IN PURE DOS?
A. Because it does not. You must run it under WIN9x using the shortcut created by the setup
program.

Actually it runs in DOS but it takes a lot of time for loading at some places.
You can speed up that by:
ykhwong build was the fastest for me,
core=dynamic
cycles=max 105%
memsize=16 (you can test 8 with "configure" in menu, but the game will need 16)
twice more memory means twice more waiting ;)
8mb memory takes 10 seconds waiting on my phenom 2000mhz

Real computers behave exactly same way with this game (for example Athlon 1GHz - 16MB - 10seconds waiting)

Of course everything loads immediately in dosbox with win9x installed.

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Mon Aug 15, 2011 2:10 pm

Looks like the "Blend on LOD" in nGlide 0.97 is broken on ALL cards. Even my HD 5730 is showing the wrong result in test 21.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1564
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide with ATi legacy cards.

Postby Zeus » Tue Aug 16, 2011 1:11 am

I tested nGlide 0.97 on Radeon HD 5670 (Catalyst 11.6) with Hype: the Time Quest and Speed Busters. No glitches at all.

Don't mix 'test21 - blend on lod' test with above titles. These do not use this technique.

PS. Rageon?

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Tue Aug 16, 2011 9:58 am

Tested. Yes, it looks like I'm seriously wrong. Test 21 is broken, but Speed Busters is not.
Can't test Hype: the Time Quest - the installer don't like Win7 64-bit.
So - I will re-design my list. Without #3, #4 etc. Just ATi glitch.

The test PC is Asus N61D with Radeon Mobility HD 5730 inside. Win7 Home Premium 64-bit, Catalyst 11.7.
Last edited by Gamecollector on Tue Aug 16, 2011 10:39 am, edited 1 time in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

robertmo
Posts: 65
Joined: Tue Jul 26, 2011 3:41 pm

Re: Nglide with ATi legacy cards.

Postby robertmo » Thu Aug 25, 2011 2:29 pm

robertmo wrote:Dreams to Reality have blinking text in text boxes during game which is probably guli's patch fault as it happens on real voodoo1 card too.

I have noticed that text is also blinking on real Pentium3 450MHz with voodoo1 (P166MMX was fine), so i tried lowering cycles in dosbox.
About 40000 cycles and less has no blinking text, more than 40000 have blinking.
So I guess nothing is wrong with guli's patch and with nglide ;)

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Fri Aug 26, 2011 6:17 am

robertmo wrote:About 40000 cycles and less has no blinking text, more than 40000 have blinking.

Added. Tnx.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Fri Sep 09, 2011 9:00 am

The latest Ykhwong build tested as the DOS glide platform.
1) All FB SDK tests are ok now.
2) Black squares glitch in "Lands of Lore: Guardians of Destiny" is now fixed.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).


Return to “Problems”

Who is online

Users browsing this forum: Bing [Bot] and 14 guests