Nglide with ATi legacy cards

Report bugs, errors, problems, etc.
Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Mon Apr 29, 2013 11:03 pm

*Censored*...
To be completely sure - d2_3dfx.exe, 1374737 bytes, 4 Mar 1998, crc32 62d4975c?

P.S. Hurrah!
The game is working correctly with the MEDIUM install size after the reinstall! I will recheck and then write the results here...
P.S.S. Ok. I have found the source of this trouble.
If you run the original descent2.exe and set the detail level to custom - the result in d2_3dfx will be as above...
Why? Why something like this is always happening to me? I just collecting PC games, and they just hate me and develop unique bugs... :(

@gulikoza: Can you please test the Battlecruiser 2.07 patch? (Memsize=16 will greatly speed main menu).
Tnx.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Tue Apr 30, 2013 4:59 pm

There is something strange with the Warzone 2100 glide version.
The screen is almost completely 1-color after the Command Center building is complete.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1564
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide with ATi legacy cards.

Postby Zeus » Wed May 01, 2013 5:57 pm

Gamecollector wrote:Ultim@te Race Pro - version 1.50 have strange transmission select screen. Not sure about the source, maybe the patch itself is broken.

Yes, the patch is broken.

gulikoza wrote:Tie Break Tennis sends 2 consecutive grSstWinOpen() calls. Previously the Glide patch returned false if window was already opened and that caused 'video mode not supported' error. Now, the patch returns true, but the second call is not forwarded to the wrapper. Opening and closing the window quickly might introduce mode switches, restarting and then again stopping dosbox rendering, that's why the second call is ignored.
But perhaps this should be handled differently, Zeus?

As long as both call parameters are equal there's nothing wrong with skipping the second call.

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Wed May 01, 2013 8:17 pm

World Cup 98 - old shadows/ball Z-level trouble.
Unfortunately this behavior is present on Radeon HD2600 and Geforce 9500M GS. So - no, this isn't looking like ATi drivers failure.

Powerslide - version 1.01+ is working almost correctly with Radeon HD2600, but there are heavy visual artifacts with Geforce 9500M.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Thu May 02, 2013 4:25 pm

Interesting.
Blood is working correctly with 3dfx patch if BUILD_640x480 variable is set to 1. Without this variable the screen is a total mess.
The screenshot resolution is 1024x768, so it looks like default resolution for Blood 3dfx is 512x384.
Is the game behavior same on a real Voodoo hardware? Or this is nGlide/DOSBox specific glitch.

Burnout: Championship Drag Racing - looks like no blinking with dialog windows in the last Ykhwong's DOSBox.
By the way, maybe someone will be so kind and share the game manual with me? My copy of the manual is long dead, and I have absolutely forgot the game controls. Tnx.
Attachments
Blood.JPG
Blood.JPG (58.89 KiB) Viewed 5002 times
Last edited by Gamecollector on Fri May 03, 2013 2:59 pm, edited 1 time in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

User avatar
Zeus
Site Admin
Posts: 1564
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide with ATi legacy cards.

Postby Zeus » Thu May 02, 2013 11:51 pm

Gamecollector wrote:There is something strange with the Warzone 2100 glide version.
The screen is almost completely 1-color after the Command Center building is complete.

Yes, game engine goes crazy in XP. The same thing randomly happens in Tutorial.

Gamecollector wrote:Interesting.
Blood is working correctly with 3dfx patch if BUILD_640x480 variable is set to 1. Without this variable the screen is a total mess.
The screenshot resolution is 1024x768, so it looks like default resolution for Blood 3dfx is 512x384.
Is the game behavior same on a real Voodoo hardware? Or this is nGlide/DOSBox specific glitch.

I'll check that.

Gamecollector wrote:Burnout: Championship Drag Racing - looks like no blinling with dialog windows in the last Ykhwong's DOSBox.

That's a great news indeed.
P.S. The lines in videos are not caused by nGlide. They are also present with original hardware.

Oh and btw, the current Ykhwong's build uses "lfb=full_noaux" by default. I contacted Taewoong and asked him to change it back to "lfb=full".

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Fri May 03, 2013 12:57 am

Extreme Assault.
Software version briefing. Software version quit screen.
Text background is transparent, there is a scan line effect. Target crosshairs aren't seen through landscape.

3dfx version 1.1.0: Briefing : broken interface panel. No "scan line" effect. Text background isn't transparent.
In-game - again, traces of the broken interface. Targets are seen through landscape. Screenshots.
After pressing "Esc" - interface, crosshairs and garbage are completely gone, no "quit game" window. Screenshot.

3dfx versions 1.2.0, 1.2.1 and 1.2.2 - the garbage problem is fixed, but there is a big black "something" (shadow?) in the upper left corner at the briefinf screen... In-game garbage is gone. Others problems are still here. Screenshots.

3dfx version 1.2.3 have fixed the "quit game" problem. Now the interface isn't disappearing and the dialog windows is drawn. Screenshot. Still - crosshairs, transparency, black "something" and no scan line effect aren't fixed.

In the glide=emu mode crosshairs, briefing text box transparency, upper-left shadow and quitting from the mission are ok. No scan line effect, so maybe this feature is software version only. The only question - quit program message background isn't transparent in 1.1.0-1.2.1. Versions 1.2.2 and 1.2.3 - quit message background is transparent.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Fri May 03, 2013 4:54 pm

Battlecruiser 3000 A.D. (1.07C patch and later) is crashing with the page fault with the Ykhwong's build from 21 Apr 2013. After pressing the "Launch" button - black screen with the blinking text cursor.
Previous build (5 Feb 2013) is working ok. Except all is rendered too dark.
Dosbox was started with "DirectX driver" shortcut, conf file is attached.

P.S. Update: I have tried to make the screenshot of the wrong Battlecruiser gamma. The screenshot have the correct colors. WtF? Unfortunately my camera isn't with me currently, so I will add the photo later...

P.S.S. Battlecruiser 3000 A.D. 2.0 - the similar crash, but now to desktop (dosbox.exe offset d7b56). Previous DOSBox build - the same "too dark" problem, starting from the version 2.07... I don't understand this.
Attachments
Battlecruiser.JPG
Battlecruiser.JPG (47.84 KiB) Viewed 4962 times
dosboxconf.7z
(8.1 KiB) Downloaded 337 times
Last edited by Gamecollector on Sat May 11, 2013 6:57 am, edited 3 times in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards.

Postby Gamecollector » Fri May 03, 2013 6:16 pm

Nascar 2 - I'm not 100% sure, but it looks like transparency troubles. Solid shade is appearing after 0,5 seconds. and if you move the cursor to the shade area - you can see the small piece of the right image.

Zeus wrote:
Gamecollector wrote:Burnout: Championship Drag Racing - looks like no blinling with dialog windows in the last Ykhwong's DOSBox.

That's a great news indeed.

To be absolutely precise - there is still a very-very little BRIGHTNESS blinking in Burnout and X-Car.

XCar: Experimental Racing - DOSBox is crashing with this game (mostly after the "Standings" screen)(module dosbox.exe, offset c7885). The offset is cf375 with the previous (5 Feb 2013) build.
If the game isn't crashing - it is working ok, blinking is gone.
Attachments
Nascar2.JPG
Nascar2.JPG (64.1 KiB) Viewed 4981 times
Last edited by Gamecollector on Sun May 19, 2013 9:20 pm, edited 1 time in total.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).

Gamecollector
Posts: 964
Joined: Fri Jan 07, 2011 9:29 am

Re: Nglide with ATi legacy cards

Postby Gamecollector » Sat May 18, 2013 3:51 pm

Added to the list:
Silkolene Honda Motocross GP, The Dawn Interactive/Midas, 1999.
If the game is quitting with the message "key verification failed" - run the game once in the "Windows 98" compatibility mode.
Asus P4P800 SE/Pentium4 3.2E/2 GB DDR400 (3-3-3-8),
Radeon HD3850 AGP (Sapphire), Catalyst 14.4 (XpProSp3).
2 Voodoo2 12 MB (SLI), Win2k drivers 1.02.00 (XpProSp3).


Return to “Problems”

Who is online

Users browsing this forum: Bing [Bot] and 5 guests