Lands of Lore 2: Guardians of Destiny

Report bugs, errors, problems, etc.
User avatar
Zeus
Site Admin
Posts: 1628
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Lands of Lore 2: Guardians of Destiny

Post by Zeus » Fri Apr 29, 2011 6:28 pm

Should I configure some settings to improve really sluggish framerate at the moment
No, nothing more can be done at the moment, but you can post your PC specs and how many fps do you see in Fraps - just for the info.

Dark Savant
Posts: 9
Joined: Wed Apr 27, 2011 5:01 pm

Re: Lands of Lore 2: Guardians of Destiny

Post by Dark Savant » Sat Jun 04, 2011 12:25 pm

Hi Zeus,

Any progress with Lands of Lore II?

User avatar
Zeus
Site Admin
Posts: 1628
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Lands of Lore 2: Guardians of Destiny

Post by Zeus » Sat Jun 04, 2011 12:40 pm

Not yet, but it's top priority.

User avatar
Zeus
Site Admin
Posts: 1628
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Lands of Lore 2: Guardians of Destiny

Post by Zeus » Sun Aug 07, 2011 5:36 pm

I've made some progress with nGlide 0.97. Cursor is now visible but it's blinking slightly. If you want to test it, make you've disabled Vertical sync option in nGlide configurator.

User avatar
Zeus
Site Admin
Posts: 1628
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Lands of Lore 2: Guardians of Destiny

Post by Zeus » Sat Nov 19, 2011 6:00 pm

Another progress with nGlide 0.98, special effects fixed, cursor blinking reduced.

User avatar
Silver83
Posts: 47
Joined: Thu Oct 13, 2011 12:25 pm

Re: Lands of Lore 2: Guardians of Destiny

Post by Silver83 » Tue Mar 27, 2012 12:55 pm

I tried LOL2 today using the newest 3Dfx enabled DosBox build and nglide. At first I had a problem regarding cycles. Setting them to 20.000 made the videos to work but 3d graphics had not enough fps. Setting cycles to 130.000 stopped the ingame graphics from stuttering but gave a bad cutscenes performance. I ended up manually adjusting the cycles using CTRL + F12/F11 every time a cutscene was played.

But now I'm in the jungle and the framerate drops to 9, 10 fps sometimes, even with 130.000 cycles.

I'm using a Core i5 2500k @ 4Ghz. Any ideas?


EDIT: And I'm getting black missing textures occasionally (water or grass).
Core i5 6600K, GeForce GTX 780, 16GB DDR4-3000, Samsung 850 Pro Series 512GB SSD, Win 10 Pro 64bit

User avatar
Zeus
Site Admin
Posts: 1628
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Lands of Lore 2: Guardians of Destiny

Post by Zeus » Tue Mar 27, 2012 7:03 pm

Silver83 wrote:framerate drops
For the best performance use cycles=auto in dosbox.conf (and don't forget to disable Vsync in nGlide configurator).
Silver83 wrote:And I'm getting black missing textures occasionally (water or grass)
I'll check this.

User avatar
Silver83
Posts: 47
Joined: Thu Oct 13, 2011 12:25 pm

Re: Lands of Lore 2: Guardians of Destiny

Post by Silver83 » Tue Mar 27, 2012 8:11 pm

I forgot to mention: Of course I tried cycles=auto. That way the game is playable but still there a slowdowns in the jungle and more important the cutscenes stutter. It seems Dosbox doesn't realize that the cutscenes require less cycles than the 3d graphics. And hey, why ain't I playing Skyrim or Oblivion...because of LOLs cutscenes :D :D

V-Sync is disabled as mentioned in your compatibility list.

Any way I can help?
Core i5 6600K, GeForce GTX 780, 16GB DDR4-3000, Samsung 850 Pro Series 512GB SSD, Win 10 Pro 64bit

User avatar
Zeus
Site Admin
Posts: 1628
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Lands of Lore 2: Guardians of Destiny

Post by Zeus » Tue Mar 27, 2012 11:25 pm

Silver83 wrote:Of course I tried cycles=auto
90% of the game works at full speed, however there are few places where fps can drop. I'm afraid you will have to deal with it until faster CPUs come out.

User avatar
Silver83
Posts: 47
Joined: Thu Oct 13, 2011 12:25 pm

Re: Lands of Lore 2: Guardians of Destiny

Post by Silver83 » Wed Mar 28, 2012 1:16 am

Guess I'll have to wait for Ivy :) But it still doesn't explain the strange cutscenes behaviour. The temple cutscene in the jungle runs great with auto cycles, the "video stones" stutter. And by the way: without hardware acceleration the game runs just great....but looks bad.

I can reproduce the missing textures by loading jungle savegames the third or fourth time.
Core i5 6600K, GeForce GTX 780, 16GB DDR4-3000, Samsung 850 Pro Series 512GB SSD, Win 10 Pro 64bit

Post Reply