Nglide 2.00, Red Baron 3D, & Odd Colours.

Report bugs, errors, problems, etc.
User avatar
ianlloyd
Posts: 7
Joined: Sat Dec 16, 2017 10:12 pm

Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby ianlloyd » Sun Dec 17, 2017 3:37 am

Hullo all,

I've been using Nglide with Red Baron 3D for a number of years, and it has always worked well, including Nglide Version 1.05. However, with Ver.2.00, there is now a colour problem -- the image size and scale are OK, but it looks as if all of the colours have been assigned at random -- sort of a sparkling, psychedelic effect.....

This includes the animated 3dfx logo which Nglide generates.

This is the original version of RB3D from 1996(7? 8? whenever...), not one of the later versions from GOG, etc. It has been upgraded with the Hell's Angels superpatch and the OTE scenery -- oh, and Greybeard's rivers -- but these have never caused any issues.

System Specs:
-------------

(1) main board (circa 2005) -- Intel P4 2.4 GHz, Intel D845GERG2 main board, 1 (count 'em, 1) GB ram

(2) video -- Nvidia GeForce 6200, 256 MB ram, driver ver. 6.14.11.9062, Aug.17.2009 -- final release for WinXP

(3) OS -- Win XP Pro SP3 -- no other mods

(4) monitor -- AG Neovo model F-419

I've tried all of the usual suspects -- colour depth, vsync, resolution, refresh rate, AA, aniso, pre-renders, acetone, blah-blah-blah, with absolutely no effect. I thought about trying Win98, but Nglide doesn't work there.

I seem to remember that RB3D always had palette switching issues. For example. the Glidos wrapper "OpenGlide_009rc9_Max256MB" that was modified by Gabi has an "IgnorePaletteChange=1" suggested setting for better performance, but that displays some "odd" colours, such as green rocket smoke. The indexed colour mode palettes may (or not) be the problem here.

One more point I should mention is that Grand Prix Legends, F22-TAW, and FreeSpace all work correctly on my museum-grade system, with no colour corruption, using Nglide Version 2.00, and WinXP.

Hm-m-m-m.......maybe I should be using Windows 2000 ???

All comments gratefully received, thanks,
===========================
Ian Hawboldt -- RB3D Forever !!

User avatar
Zeus
Site Admin
Posts: 1553
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby Zeus » Sun Dec 17, 2017 4:46 am

I think it must be correlated to your monitor ICC color profile. Could you please send me an .icc/.icm file for you monitor?

User avatar
ianlloyd
Posts: 7
Joined: Sat Dec 16, 2017 10:12 pm

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby ianlloyd » Sun Dec 17, 2017 5:18 am

Sorry -- I must be goofing up.
I keep getting "Invalid File Extension" when I use the "Add Files" button or drag-and-drop.....
===========================
Ian Hawboldt -- RB3D Forever !!

User avatar
Zeus
Site Admin
Posts: 1553
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby Zeus » Sun Dec 17, 2017 5:30 am

Please .zip it.

User avatar
ianlloyd
Posts: 7
Joined: Sat Dec 16, 2017 10:12 pm

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby ianlloyd » Sun Dec 17, 2017 5:36 am

FWIW:

I stripped out the ICM file using the MS Colour Applet -- rebooted -- checked that the profile really was gone in control panel settings, and ran RB3D.....

But the colour corruption is still present -- double hm--m-m-m..

Ok -- seems the zip attachment works.

The icm file was produced by Quick Monitor Profile, which is part of the QuickGamma package.
Attachments
F419.zip
(545 Bytes) Downloaded 45 times
===========================
Ian Hawboldt -- RB3D Forever !!

User avatar
Zeus
Site Admin
Posts: 1553
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby Zeus » Sun Dec 17, 2017 5:42 am

Any difference with this glide2x.dll file (extract it into game directory)?

User avatar
ianlloyd
Posts: 7
Joined: Sat Dec 16, 2017 10:12 pm

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby ianlloyd » Sun Dec 17, 2017 5:58 am

sorry -- deleted the dll, rebooted, unzipped the test version, checked with the configurator -- all settings are default -- still showing corrupted colors.

Even the whites on the 3dfx logo change colour as it revolves.....
===========================
Ian Hawboldt -- RB3D Forever !!

User avatar
Zeus
Site Admin
Posts: 1553
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby Zeus » Sun Dec 17, 2017 6:05 am

Something is interfering with gamma ramp on your PC (I cannot reproduce the bug on my side). We will continue tomorrow.

User avatar
ianlloyd
Posts: 7
Joined: Sat Dec 16, 2017 10:12 pm

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby ianlloyd » Sun Dec 17, 2017 4:29 pm

BINGO -- done like dinner !

I disabled QuickGamma and the odd colours vanished -- all is back to normal.

I'll have to check Adobe Gamma to see if has the same side-effect. I'd rather not resort to tweaking the monitor's hardware settings, but RB3D outvotes Photoshop any day of the week..... ;)

Many thanks, sir !
===========================
Ian Hawboldt -- RB3D Forever !!

User avatar
Zeus
Site Admin
Posts: 1553
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Nglide 2.00, Red Baron 3D, & Odd Colours.

Postby Zeus » Sun Dec 17, 2017 4:46 pm

I would like to see gamma table the program produces on your PC. Please restore a psychedelic state and launch the game with this glide2x.dll file. It will create gamma.dat in a game folder. Zip it and attach it here.

PS. Which version of QuickGamma do you use?


Return to “Problems”

Who is online

Users browsing this forum: No registered users and 4 guests