Page 1 of 1

NGlide 2.00 color problems.

Posted: Sun Dec 17, 2017 3:19 am
by Bloodbat
Hi! I downloaded the latest nGlide and every game I've tried (Deathtrap Dungeon (Steam), GTA DOS, Tomb Raider 1 and Carmageddon) outputs the wrong colors, like an "acid trip" effect or one of those old "plasma" palette MS-DOS programs, palette shifting effects and all... I tried capturing a screenshot with NVidia ShadowPlay but that shows the correct colors? :S All those games used to work fine with 1.05, the system is a Windows 7 machine with an NVidia 750 GTX Ti using the 388.59 (the latest at the time I wrote this), I'm using the DirectX backend, since Vulkan hangs DosBox (haven't tried it with Deathtrap Dungeon) am I missing a configuration option or doing something wrong that changed between versions?
Thanks in advance :)

Re: NGlide 2.00 color problems.

Posted: Sun Dec 17, 2017 4:44 am
by Zeus
Bloodbat wrote:Hi! I downloaded the latest nGlide and every game I've tried (Deathtrap Dungeon (Steam), GTA DOS, Tomb Raider 1 and Carmageddon) outputs the wrong colors

I uploaded a new installer today that fixes the problem (http://www.zeus-software.com/downloads/nglide).

Bloodbat wrote:I'm using the DirectX backend, since Vulkan hangs DosBox (haven't tried it with Deathtrap Dungeon)

Please do and let me know if it hangs too.

What is your version/build of DOSBox?

Re: NGlide 2.00 color problems.

Posted: Mon Dec 18, 2017 2:12 pm
by Bloodbat
Thanks the colors are fine with the new version :)
I tried Deathtrap Dungeon with Vulkan and it works fine :)
As for the DosBox version is a custom build that follows SVN with several custom patches, including the one for Direct3D output.