Page 1 of 1

Lewpy's glide works but too slow?

Posted: Thu Nov 09, 2017 10:50 am
by tgod
I've never had any problems with nglide before until i tried this. The lewpy glide plugin for epsxe doesn't run at 100% speed for me with it. The speed sort of varies depending on what's going on ingame. Anyone else have this issue?

Re: Lewpy's glide works but too slow?

Posted: Fri Dec 15, 2017 5:05 pm
by Zeus
What is your PC specs and OS? Which games did you test?

Re: Lewpy's glide works but too slow?

Posted: Tue Dec 19, 2017 7:30 pm
by tgod
The new Vulkan backend fixes it for me, so i guess problem solved? Maybe my weak single core performance was causing the issue while vulkan should take more advantage of my other cores compared to dx9 which is single threaded.

AMD FX-8350
Geforce 960.
12gb ram.
Windows 10

Re: Lewpy's glide works but too slow?

Posted: Thu Dec 28, 2017 11:23 pm
by Zeus
Good. That's exactly what I was going to suggest next.

tgod wrote:Maybe my weak single core performance was causing the issue while vulkan should take more advantage of my other cores compared to dx9 which is single threaded.

Not only that, it's also couple times faster when it comes to texture memory access.

tgod wrote:The new Vulkan backend fixes it for me, so i guess problem solved?

I'm still interested with titles you tested with it.

Re: Lewpy's glide works but too slow?

Posted: Fri Dec 29, 2017 9:18 pm
by tgod
I made a video of the problem with Mega Man Legends 2, you can see the FPS counter (top left) start to lower right when I try to move the camera in the larger areas like this city. If I use Vulkan instead there's no longer any FPS drop like I said before.

https:/www.youtube.com/watch?v=B5R6HzSfW44