Page 1 of 1

4x4 Evolution

Posted: Tue Sep 05, 2017 7:17 pm
by daan
Hi

Recently I've tested 4x4 Evolution from Terminal Reality that I've played long time ago and it doesn't work with nglide.
When I run 4x4 Evolution and set renderer to glide, there's no 3dfx logo, game renders in software and text menu is in upper left corner out of place, so nglide doesn't work?
The game isn't in gallery or in compatibility list on this site, so maybe it wasn't tested at all.
There is Monster Truck Madness 2 game by same developer so maybe it's something similar.
In game directory there's triglide.dll file and when I delete it, game switch to software mode without bugs I've mentioned earlier. Text menus are fine.
Could You look into this, please?

4x4 Evolution patch build 57
Win xp 32bit

Re: 4x4 Evolution

Posted: Fri Sep 08, 2017 2:01 pm
by Gamecollector
Have tested build 44 and build 57. Work ok with nGlide 1.05.
3dfx logo after the intro movie etc.

Please list specs for your PC.

Re: 4x4 Evolution

Posted: Fri Sep 08, 2017 7:21 pm
by daan
Win XP SP3 32bit
AMD FX4100
4GB RAM
Radeon 6850

This game have problems with modern graphic cards. You have 3850 so maybe that's why it's running without problems.


Here's legal version of 4x4 Evo for free:
http://vales.com/evo1/freeEvo1.asp

Re: 4x4 Evolution

Posted: Thu Sep 14, 2017 8:55 pm
by Zeus
daan wrote:http://vales.com/evo1/freeEvo1.asp

@Gamecollector: does this version work for you as well?

Re: 4x4 Evolution

Posted: Fri Sep 15, 2017 8:01 pm
by Gamecollector
@Zeus: Yes.

Re: 4x4 Evolution

Posted: Sat Dec 23, 2017 10:27 pm
by daan
Sorry for break. Haven't had time.

I've tested 4x4 evo again and the 3dfx logo shows up to 1152x864 resolution but menus and everything is big as in 640x480, so that's something wrong. At resolutions higher than 1152x864, 3dfx logo doesn't show, so that's the nglide bug (as in Powerslide). Earlier (as described in 1st post) I've been testing game at 1280x960 that's why I didn't notice that.
At 1024x768 3dfx logo show up and menus are properly scaled, so that's the highest good working resolution.
The game can be played at only 16bit colour mode in glide mode. I don't know if it's nglide bug or game limitation, because in software, dx7, opengl renderers game works at 32bits. Could it be fixed?

I've tested nglide 1.05 and 2.00 with same results.

Re: 4x4 Evolution

Posted: Sun Dec 24, 2017 10:34 am
by Gamecollector
Glide API supports 1280x1024 and 1600x1200.
Of course 1280x960 and 1152x864 not work and the game switches to 640x480.

Re: 4x4 Evolution

Posted: Sat Jan 13, 2018 8:12 pm
by daan
@Zeus: Any chances of fixing it?

Re: 4x4 Evolution

Posted: Mon Jan 22, 2018 3:03 am
by Zeus
If I didn't state otherwise there's always a chance. It's just I can't fix everything at once and nGlide "things" usually have higher priorities than modern operating game fixes. ;)