Page 2 of 6

Re: Archimedean Dynasty / Schleichfahrt

Posted: Sat Nov 19, 2011 7:58 pm
by gulikoza
Screenshot seems great, will check it out :D
Amazing job!

Re: Archimedean Dynasty / Schleichfahrt

Posted: Sat Nov 19, 2011 8:25 pm
by Zeus
Don't forget to disable Vsync in configurator.

Re: Archimedean Dynasty / Schleichfahrt

Posted: Mon Nov 21, 2011 8:08 pm
by Zod
Thanks for this great work with nglide.

Can somebody please write a guide how to run achimedean dynasty with dosbox+nglide?

-i use win7 x64. for dosbox. i extracted the version (20111012) from ykhwong (
-installed the game + patch + 3dfx patch
-installed nglide 0.98
-deleted glide2x.dll in doxbox folder
-the "SF.EXE" runs without any problems, as far as i tried
-the "SF3DFX.EXE" starts with the spinning 3dfx logo, but it is impossible to play when in water due to massive flickering and other visual problems... i dont have the feeling that nglide is used.

(use nglide with pod gold from GOG, which runs really nice)

hope somebody can help me :D

the problem is solved: the "glide2x.ovl" in the game folder needet to be deleted.
now the game runs very well :)

Re: Archimedean Dynasty / Schleichfahrt

Posted: Thu Dec 22, 2011 4:27 pm
by Silver83
OMG! It works! For the first time since I purchased the game in 1997 it WORKS! Thank you so much!

Re: Archimedean Dynasty / Schleichfahrt

Posted: Sat Apr 07, 2012 2:51 pm
by OldByte
I thought I write a step by step guide for the people who want to run this cause I had some problems getting it to work with the information supplied, but I got it to work finally.
  • Install nGlide if you haven't done so yet ;) , my version is 0.98 at the time of this writing.
  • Download and install ykhwong DosBox.
    Then go to the folder where this is installed, C:\ProgramFilesx86\DOSBox SVN-Daum\, and delete/rename glide2x.dll.
  • Start DosBox SVN-Daum once, exit it, and open dosbox-SVN-Daum.conf with notepad, you can find it in the C:\Users\%username%\Appdata\Local\DOSBox\ folder (Vista/7) or C:\Documents and Settings\%username%\Local Setting\Application Data\DOSBox\ folder (XP). Search for the line memsize=16 and change it to memsize=63, save and exit notepad.
  • Install Archimedean Dynasty within DosBox.
  • Install the 1.120 patch, just extract and overwrite the files in your Archimedean Dynasty folder.
  • After that install the 3dfx patch, again just extract and overwrite the files in your Archimedean Dynasty folder.
  • Now go to the folder where you have installed Archimedean Dynasty and delete/rename GLIDE2X.OVL.
  • Open nGlide configurator and turn OFF the vertical synchronization.
Ok now you're all set, just run DOSBox SVN-Daum, mount your drive and cdrom, start AD3DFX.EXE et voila.
If you have problems with DosBox itself, like installing the game and running it, I suggest to type INTRO at the command prompt and read the instructions carefully also the provided README contains a lot of useful information. Alternatively you can read this quickstart guide.

Optionally if you use a widescreen monitor and don't want a stretched screen, set aspect ratio to 4:3 in the nGlide configurator and in the .conf file set aspect=true. If you are using a joystick and it is too jittery set timed=false.

Re: Archimedean Dynasty / Schleichfahrt

Posted: Sun Apr 22, 2012 10:59 pm
by M[u]ddy
There still seems to be a small issue. When trying to force Anti Aliasing, the 3D area stays black with drags of the GUI.
Other 3Dfx games in DOSBox work fine with Anti Aliasing.


GPU: AMD Radeon HD 6950
OS: Windows 7 x64 Home Premium

Re: Archimedean Dynasty / Schleichfahrt

Posted: Fri Aug 31, 2012 5:11 pm
by cipactli
Thank you for this thread. AD was my favorite game.

I am new to this stuff, I did however manage to get Colonization to mount, install and work with DOSbox 0.74. When it installed it created a real folder to my C drive and the patch was easy to apply manually.

However when I mounted AD on the ykhwong DOSBox SVN Daum (8. 23. 2012) For Windows, I did it in the similar way, by copying my Archimedean Dynasty CD contents into C:\ADCD, the adding the mount command something similar to

mount c c:\ADCD

to the bottom of the dosbox-SVN-Daum.conf on notepad and saved it. I then ran the DOSbox and it gave me the installation screen as should, I installed it to C:\BLUEBYTE\AD and confirmed it by checking dir command and it showed that it had installed.

However in my Win7 Home Premium x64 there was no such folder as C:\BLUEBYTE\AD (unlike with my Colonization install).

My question now is: How to apply the AD patches, when in fact I have no idea where my AD physically installed. I suppose the folder is some kind of a virtual folder within DOSbox?

Please advise. And thank you for your work.

Be well.

Re: Archimedean Dynasty / Schleichfahrt

Posted: Fri Aug 31, 2012 11:54 pm
by gulikoza
If you mounted c:\ADCD to c: then C:\BLUEBYTE\AD should be in C:\ADCD\BLUEBYTE\AD.
But you should actually leave the CD in place and mount it on D: as CDROM and mount C:\Games (or c:\dosbox or something similar) as C: and install it there.

Re: Archimedean Dynasty / Schleichfahrt

Posted: Sat Sep 01, 2012 12:07 am
by Zeus
Just read official DOSBox tutorial and everything will be clear.

Re: Archimedean Dynasty / Schleichfahrt

Posted: Sat Sep 01, 2012 10:56 am
by cipactli
Ah of course. Thank you very much. That bottle of wine certainly didn't help me solve things.

Ah well, I am getting the incomplete cockpit hud and the bullet tracers drag on the screen, just like the previous screenshots combined.

I am using Inter Core i5-2410M, (NVIDIA GeForce GT 540M card currently disabled if that matters), Windows7 Home Premium x64.

ykhwong DOSBox SVN Daum (8. 23. 2012)
nGlide 0.99
my own Archimedean Dynasty CD
1.120 patch
3dfx patch

AD folder:
I removed GLIDE2x.OVL

DOSbox configuration:
I set memsize=63

nGlide configurator:
Aspect Ratio to 4:3
vertical synchronization to OFF

I was running the ad3dfx executable and the videos worked fine, game speed was good. There were some delays and sound disturbances when entering to fit weapons to the ship at the dock. Also on fullscree the DOSbox menus are visible on the top. The biggest problem however is the cockpit and the tracers.

Any advise on how to progress from here?

For now I tried running the ad and ad2 files and it managed to mess up my installation. I think I'll reinstall it at some later time to continue.

For anyone interested:

You can edit your save game credit balance at Bluebyte\AD\Dat\Save on NotePad, set

Name = YourSaveName
Credit = 2000

Name = YourSaveName
Credit = 99999

Thanks and have a good weekend.