Bug in Carmageddon 2

Report bugs, errors, problems, etc.
natas_hell
Posts: 1
Joined: Sat Jun 26, 2010 10:03 pm

Re: Bug in Carmageddon 2

Post by natas_hell » Sat Jun 26, 2010 10:15 pm

hi there!

i'm having exactly the same problem than morchaiel...

my OS is WIN 7 64bit on a Fujitsu-Siemens AMILO PA 3553 laptop that carries an AMD Turion X2 64 processor and the following graphic cards: HD3400 Series in crossfire with integrated HD3200 Series.

my graphic drivers are up to date, from ati. omega drivers doesn't have yet WIN 7 drivers for those graphic cards

hope there's a solution for i am a old carmageddon fan (since it did get out) and want to continue playing

thank you!

User avatar
Zeus
Site Admin
Posts: 1643
Joined: Sun Sep 21, 2008 2:51 pm
Contact:

Re: Bug in Carmageddon 2

Post by Zeus » Mon Jul 05, 2010 3:04 pm

tracks with colored fog present artifacts
Fixed in nGlide 0.93
missing the high res support
Added in nGlide 0.93
using the super-patch v2 the mouse issue
Added to compatibility list
minimap slowdown
Should be faster with nGlide 0.93. I have 60fps on GF 9800GT in 640x480.
entire screen goes black
Try nGlide 0.93 and see if there's a difference with nGlide 0.92.

User avatar
Toshiba-3
Posts: 23
Joined: Mon Mar 22, 2010 12:47 am
Location: Belgium/France
Contact:

Re: Bug in Carmageddon 2

Post by Toshiba-3 » Fri Jul 09, 2010 12:56 pm

Hello, 0.93 is a great improvement!
Thanks a lot for the high res support and the gamma correction drop down menu.
The fog artifacts are indeed gone 8-) This now makes your glide wrapper the one with the best support for C2!
I did some test with the minimap slowdown: there's indeed a great improvement, the framerate went up from 15fps to 40fps (60 out of the minimap), but that's only when there's not much onscreen. It seems like it's much more sensitive to onscreen geometry/polycount once it's in minimap view!
Still this isn't a major bug at all for players. Your wrapper clearly seems like the one to get nowadays.

Keep up the good work :D
Image / carmageddon add-ons at road reaction

GannMan
Posts: 2
Joined: Fri Jul 15, 2011 9:39 pm

Re: Bug in Carmageddon 2

Post by GannMan » Fri Jul 15, 2011 9:49 pm

Hey I installed nglide for carma2 also and it actually made the game not work at all. It has the option for glide but it doesnt do anything when I try to start it. But I couldnt find the uninstall anywhere and I registered here to post a thing asking where the hell it was. It was only mentioned once in another forum so I knew it existed somewhere.

Anyway after registering I stumbled on this post where you mentioned that on Windows 7 64bit (my OS) the files are installed to C:\Windows\SysWOW64 so I decided to search it, and to my relief its there.

Something like this shouldnt be tough to find as after installing something like this it can gimp all your programs and wanting to play a game for an hour turns into fixing your machine all day. I hope this helps anyone else who cant find the unstaller.

EDIT: Also it seems the uninstaller doesnt clean out everything. My game still wont start, before installing this wrapper the game worked fine in every way except sound and I cant figure out anyway to get the sound to work. After installing this the game wont start, and after uninstalling it still wont start. it also says I can still use glide which shouldnt be true. Installing the other glide wrapper which has worked before, I did it last week, it says there are other glide files in the folder that can be from legit voodoo drivers or other glide wrappers and these will need to be deleted before it will work. Now I dont wanna go on a search and destroy taking stabs at which files its talking about. Anyway I'm back to no wrappers installed, but now with a newly not working game. Could it be that if its pointing to files in the wrong directory that the uninstaller deleted those instead of the right ones? Which files should I look to delete?
Last edited by GannMan on Fri Jul 15, 2011 10:41 pm, edited 1 time in total.

GannMan
Posts: 2
Joined: Fri Jul 15, 2011 9:39 pm

Re: Bug in Carmageddon 2

Post by GannMan » Fri Jul 15, 2011 10:35 pm

Ok after fiddling i found that glide2x.dll was still in there. Trying to delete that it said I couldnt cause carma was using it. So i ended the process and deleted it. the other wrapper works now and carma starts again. I checked for carma in the process list a few times but I guess I must have overlooked it everytime.

I might try to install this again cause I really want sound, I just dont know where it went wrong.

Joergen8
Posts: 3
Joined: Sun Oct 09, 2011 10:26 pm

Re: Bug in Carmageddon 2

Post by Joergen8 » Sun Oct 09, 2011 10:34 pm

edit: RESOLVED; issue is not nGlide related, but final game's Eagle3-related.
--------------
Hey!

First, congrats on a great job with this glide emulator, I was able to play one of my favorite PC games Carmageddon 2 for the first time in 10 years! I just installed the XP patch and nglide and was playing in glorious vsynced 60fps at 1680x1050 in no time, with my 5 year old A64 2200+, 2GB RAM and 256MB Geforce 6800GT! Game runs supersmooth not a blip or hiccup in sight. :shock:

Then after a couple hours of playing I started thinking the textures are too low on the cars, I distinctly remember C2 with my Voodoo2 having far better textures than when running in D3D mode and sure enough, nGlide seems to be running the 32x32 textures instead of the 64x64 ones (or something to that effect).

Unfortunately I dont have the ability to fire up an old native Voodoo2 setup and I tried franticly to find screenshots from my old backup discs but I only found shots taken from the demo or beta, but you can see the comparison here and it is valid for the rear lights for the full version. Another good way to check the texture rez is to read the goodyear logo text on the side doors of the Eagle3 car (first car).

Again, thank you for this NEAR PERFECT way to enjoy this game and many others. If the texture issue can be resolved then most people would see C2 with high res textures for the first time (since most back in the day had nvidia riva or ati rage3d etc setups for D3D only). And also fixing this would do the modding community better justice and their beautiful hires textures could be appreciated fully. 8-)
Attachments
nglidevsvoodoo.jpg
nglidevsvoodoo.jpg (24.78 KiB) Viewed 6691 times
Last edited by Joergen8 on Mon Oct 10, 2011 10:17 am, edited 2 times in total.

Joergen8
Posts: 3
Joined: Sun Oct 09, 2011 10:26 pm

Re: Bug in Carmageddon 2

Post by Joergen8 » Sun Oct 09, 2011 10:55 pm

Here is the door shot, nGlide is direct buffer grab to photoshop and Voodoo2 is a native framebuffer dump from the original game with some JPG compression. The riveted side panels are from the beta/demo. Thanks!
Attachments
dump00M8.jpg
dump00M8.jpg (25.53 KiB) Viewed 6689 times

Squall Leonhart
Posts: 68
Joined: Wed Jun 01, 2011 11:55 pm

Re: Bug in Carmageddon 2

Post by Squall Leonhart » Mon Oct 10, 2011 8:02 am

Joergen8 wrote:Here is the door shot, nGlide is direct buffer grab to photoshop and Voodoo2 is a native framebuffer dump from the original game with some JPG compression. The riveted side panels are from the beta/demo. Thanks!

Only the demo/beta appeared like that (As confirmed on the Carmageddon website)
the final release was blurry and detail-less
Concept Rendering:
Image
Alpha:
Image
Beta/Demo:
Image
Final:
Image

The Eagle 3 through its many design stages. You can see that first of all the Hawk 3 as it is in game was originally supposed to be the Eagle 3, it is extremely rare that a vehicle from such an early design stage should even get near to making it into the final game but this early rendering did make it in but in the form of the Hawk 3.
Next up you have the Alpha Eagle 3, this Eagle is from the early preview screenshots of C2. There's a lot of differences
between this and the Beta/Demo Eagle, they are as follows:
1. The door is a completely different shape
2. It's wider, shorter and flatter
3. The bonnet is longer
4. The bonnet is almost higher than the cockpit
5. It has no interior (as the game was closer to being like C1 than C2 at the time of the preview screenshots)
I found this version of the Eagle 3 in the Alpha C2 demo (it's also in the regular demo), in the "/data/MODELS" it also has a material (.MAT) file and an actor (.ACT) file and I've got the vehicle working as an opponent in the Alpha demo.
I'm working on porting this version of the Eagle to C2. Here is a screenshot of it in the C2 Alpha demo (and a good comparison against the Beta/Demo Eagle 3):
Image
The beta/demo Eagle 3 is a more finalised version of the Eagle 3, the main differences between this Eagle 3 and the final version are as follows:
1. Steel bumpers
2. Black spikes
3. Different bonnet shape
4. Some textures are at a higher resolution than the final Eagle 3
Personally, I think that this Eagle 3 is much better than the final version as it looks much more badass. I released the beta/demo Eagle 3 as a download for the final version of C2. If you want to use it as a replacement, just click the CarImage below to download it:
Image
The final Eagle 3 seemed a lot different to the Alpha/Beta versions, it has black (plasticy) bumpers and white spikes and the textures appear to have been reduced in size considerably from the beta version of the car.

Joergen8
Posts: 3
Joined: Sun Oct 09, 2011 10:26 pm

Re: Bug in Carmageddon 2

Post by Joergen8 » Mon Oct 10, 2011 9:40 am

Wow! Thanks for the detailed explanation/quote. I downloaded the beta eagle and indeed the rear lights are now hires. I must have been really disappointed with the final game eagle3 back in the day, just didnt remember it :?

So, nGlide was even more perfect than I was willing to admit! 8-)

Post Reply