Search found 2 matches

by drcho805
Sat Apr 09, 2016 6:56 am
Forum: Problems
Topic: Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.
Replies: 8
Views: 10763

Diablo2 - Lord of Destruction has been updated to 1.14b and cannot run.

Hello, I am playing Diablo2 - Lord of Destruction via nGlide. Yesterday, I installed Diablo2 1.14b patch and it cannot be run. I could play diablo2 before installing the patch clearly. How can I do about this problem? Lastly, I am using Windows 7. Please let me know the solution if you could solve i...

Go to advanced search